So did you try to root AFTER you installed the update from droid-life? Or just before when you had 2.0.1?

Because even if you had root on 2.0.1, when you installed the stock 2.1 from droid-life it removes root. You just installed STOCK 2.1, you would have to root it again too
i had to root to get the update, my phone has the superuser permesions
The way I back everything up is, go into Rom Manager (Free App from Android Market), go down to the bottom where it says Flash Alternate Recovery 'SPRecovery 0.99.3B', click that and it will will make your recovery screen at bootup that of SP Recovery (I don't know if this is the most efficient way, I just know it works for me). After it goes to SPRecovery, you will notice that alot of the Rom Manager options are grayed out and at the very top of the menu in the Recovery section, it should read Current Recovery: SPRecovery 0.99.3, and Latest Recovery: ClockworkMod1.8.0.8. (Regardless, we are looking for the SPRecovery part).

Now just below all of that you should see an option called Reboot Into Recovery, click it and it will ask you if you want to reboot into SPRecovery 0.99.3, click OK.

The phone will reboot and automatically go into recovery mod, and you will notice at the top it will (or should) Android System Recovery <2e> and Patched by SirPsychoS (0.99.3b), plus you will see a little yellow droid in the middle of the screen. Now, us the Volume Down Key to move down to the option that says "backup/restore", then use the camera button to select it.

The next screen will present you with 4 options, you Simple nandroid backup, Simple nandroid Restore (latest), Advance Nandroid backup, and Advance Nandroid Restore. Select Advance Nandroid backup.

The next screen will present you with quite a few options, Set Backup name, Perform Backup, (*) backup BOOT, ( ) backup CACHE, etc. You should see what I'm talking about. What you want to do is use the Volume Down key to move to the options that do not have Astericks (*) in them, and use the Camera button to put one there. So basically every option should have a asterick/star in between the parenthesis.

Once you do that, select Perform Backup, and it should start backing up all of your current phone setting, to include you ROM, your shortcuts, everything except for your apps (which you should have already backed up on your SD Card with Astro.

Once that is all done, you can reboot your phone normally. Now if you plug in your phone, and go to the SD Card, you will notice a new folder called "nandroid". Inside of that will be a folder with a random name assigned to it. That is your Nandroid backup, you can rename that folder whatever you want as long as there are no spaces (im not sure if periods are allowed or not, I would just stick to numbers, letters and hyphens).

So now that you have a backup of your current state, you can now venture into other ROMS without the worry that you can't easily get back to where you are now. I'd still recommend following proper installation instructions of the ROM you are looking into, which all pretty much tell you to Wipe cache and Data, which I will explain next.

If you decide to change ROMS and don't like the new one, just reboot into SPRecovery like I explained before.

Go to "wipe cache partition", select and run it. Then select "wipe data/factory reset", the next page should have a bunch of “No’s” on it, scroll the the only one that says yes and select it. After those are complete, select "backup/restore", then "Advance Nandroid Restore", then "Choose Backup". Inside of "Choose Backup" you will notice the nandroid backup folder that you did (it will either be the default name or the custom name you gave it). Select it, then it should take you back to the screen with all of the restore option. Make sure all of the option have an Asterisk/star in them, then click "Perform Restore". It will start restoring everything that you backed-up in the previous steps that we took.

The above method of nandroid restoring is also a method used to install ROMs also. Developers like The BlackDroid (Ultimate Droid) post a link to the nandroid backup version of there ROM. You can dowload that and place it in the Nandroid folder of your SD Card, then reboot into SPRecovery, do the data/factory wipes that I talked about before, then go navigate to the Advance Nandroid Restore, except this time you only need "restore BOOT", "Restore Data" and "Restore System" selected with Asterisks/stars. Then you go into "Choose Backup", select the ROM nandroid backup folder that you put in there, then go back and select "Perform Restore"

Again, if anyone finds any discrepancies in my statements, please correct me.
Last edited:
welp it looks like im just stuck where im at i have tried everything and nothing works thanks for the help
I have screenshots of each step, but I haven't compiled everything into a single write-up yet.
But Pokebreaker, if he is not rooted properly, ROM Manager will error out on everything he tries to do in it
Yeah I was thinking that, but he had said that superuser and all the other root stuff was on his phone and working....
So when did this error come up? What did you do prior to that? What did you put on your card? What app did you run?

intalling update...
assert failed: !less_than_int(1259199777.getprop("ro.build.date.u tc"))
E: Error in .sdcard/update/zip
(Status 7)
Installation aborted
nothing, when i run DM updater to root it when i go to sp recovery and try to aply the update it gives me
E: eocd marker occurs after start of eocd
E: signature verification failed
installation aborted
Man, I don't know what to tell you at this point. My last resort option is just to Flash with RSD, but that doesn't seem to be an option for you.
can i still get UD on my phone

I don't know. Thought of another question:

Is your phone the Motorola Droid?
I ask because while the European version, the Milestone, can be rooted it can't flash roms. If you do not have the Droid, skip the rest of the steps below.

As a recap to see where you are at and to do some further testing:
1) Can you follow, successfully, all the steps in the 3rd link in my signature and when you power up and check the about phone settings see you are on 2.01?
2) Can you follow the first 6 steps in the first link in my signature, go to the market, get Android Terminal Emulator, open Terminal Emulator in your app drawer (I know, market name doesn't match app name) type su at the prompt and have the # symbol come up? You also should be able to type whoami after typing su and have it tell you you are unknown userid 0
3) Can you then follow steps 9-26 to install sprecovery and create a nandroid restore file, from link 1 of my signature?
4) repeat step 2, checking to make sure you still have root after rebooting your phone twice (just to make sure). At this point you have a saved nandroid recovery file of 2.01 rooted.

5..if all of the above work you then should be able to do the install from the following link Ultimate Droid 9.8.0 Built From Source, Fast, Working 3DLauncher!!!

I do see there are different files you can grab for the install. Maybe it is at this point that the wrong update.zip is being applied. I have not installed UD yet so before proceeding can you post what you would like to do, with the name of which file and which steps you are about to take, so someone can confirm you are about to take the right steps?

Good luck. Looks like it was a long night last night, but you were in very good hands. The advice couldn't have been better that you were getting, it looks like all concerned, including you, were doing all the right steps to get a Droid rooted and a rom applied.