Did you highlight your device, where it says connected? It should populate information int he top left box of RSD lite.
i have the file and everything i just can click start for some reason
yes click on my device and most of the info in the box says N/A still cant click start
Ok, which USB Drivers did you download? 32-bit or 64-bit?

Also, where did you save the .SBF file to?
i have the 32bit drivers and i saved the sbf file to my desktop
Ok, what windows operating system are you running?

And do you have RSD Lite set to Run As Administrator?
Hmm, well you have everything configured correctly. Try opening up the device manager and see if there are any discrepancies in there, like maybe a mis-installed driver.
i have tried every thing to get UD running on my phone but nothing it working
So tell me this, are you running into any problems while using the phone regularly?
my phone works fine i was going to use rom manger but i get an error
Did you ever run the Fix Permissions option in ROM Manager? This usually fixes a lot of issues and that's what it is there for
i have the ninja in my apps and i wanna get a cool rom on here but every time i run droid mod it says my phone is not rooted