The X2 issues: poor programming?

greycobalt

Member
Joined
Dec 16, 2010
Messages
136
Reaction score
1
Location
Southern California
My X2 had a bunch of insanely annoying problems. They got fairly bad, so I called Verizon and they sent me a "certified" refurbished replacement. Upon simply turning on the replacement, it froze. I had to pull the battery. This time I got to the setup screen. When I hit the button to activate the phone, it froze. Had to battery pull. It did this three more times before I almost crushed it Hulk-style. I switched back to my first X2, factory reset it, and installed Eclipse.

Since then, it's been flawless. None of the lag issues. No keyboard lag or non-input. No dial lag or input. Some sound stutters still, but it's nowhere near as bad. The lag is completely gone. So are all of the major issues I had with my phone just the result of some fairly poor programming and optimization? That's what it seems like to me at this point.
 

Versatile1

Premium Member
Premium Member
Theme Developer
Joined
Aug 27, 2011
Messages
354
Reaction score
11
Location
USA
Froyo sucked but the GB update was decent in my opinion. Not as clean as Eclipse but then again it is debloated.

SENT FROM MY DROID X2 USING ECLIPSE ROM GB 2.3.3 + BNB CUSTOM THEME
 
OP
greycobalt

greycobalt

Member
Joined
Dec 16, 2010
Messages
136
Reaction score
1
Location
Southern California
I was still having all sorts of issues even after I had GB. Weird. I wonder what causes some to crap out and others to work fine.
 
Top