Something Wrong With My D1


Dec 7, 2009
Reaction score
First off, it's my wifes D1, I gave it to her when I got the DX, it's been rooted and has been running Chevyno1's Simply Stunning ROM with no issues until now. When you power the phone up you can see the backlight light up, you get no "M" logo, after a bit the bottom buttons light up, you can feel around where the slide to unlock would normally be and it vibrates like it's there, but you can't see a damn thing. I've tried rebooting several times, I've also tried booting into recovery mode by holding down "X" while turning the power on, that to seems like it goes into recovery mode just fine because I can press on the camera buttong after I believe its booted into recovery and it will reboot the phone, that's because the first option in recovery is "reboot system now". Is there anything I can do or do I need to get a replacement phone shipped out? Can I try to RSD it back to stock?? If so, what file do I need to use and does anybody have the post for step by step RSD instructions?

Thanks in advance.
Sounds like a hardware failure, specifically the display. You could probably get a Froyo .sbf file and RSD back to stock.

I would use the thread and just use the instructions for the RSD portion.

There are some Froyo SBF files here: Peter Alfonso.

Curious, though, are you still under a warranty/insurance program? Otherwise there's not much reason to SBF to stock other than to see if it's a software issue and not a hardware issue.