Rooted D1 - Stuck in repeated FCs and bootloops only with SD Card inserted...!?


Mar 26, 2010
Reaction score
Hey everyone. I've got a rooted D1 that I love to death. I'm an obsessive ROM flasher - I love to check out new stuff, but MIUI has been my main squeeze as of late (1.2.5, to be specific). I flashed 1.3.11 because I figured it would just be the latest and greatest, but since then, I've been unable to keep the phone up for more than a minute or so before it restarts of its own volition. I can't get anything from my last backup restored and I've tried all sorts of different kernels just to make sure it wasn't a kernel conflict.

After that, I tried flashing all the latest ROMs - Liquid Gingerbread, Ultimate Droid (which I really like, and actually would like to keep using if I can get this figured out), etc, all with various combos of kernels. Nothing works. I've wiped everything multiple times.

Here's the weirdest part: when I remove my SD card, the phone "works" - that is, it doesn't keep restarting, and I can make calls. Obviously a D1 without an SD card is basically a paperweight, so I'd like to back up my card and format it (maybe something on my card is corrupting my system?) but I can't keep the phone up long enough to get the phone and the computer to talk to each other.

Anyone have ANY ideas? I'm fresh out and it's really starting to bum me out here.


Super Moderator
Mar 10, 2010
Reaction score
deep in the heart of texas
You can use and adapter and connect your sd card to your computer, pull all the important stuff off and then format. Dont put anything back on it until you have made sure it works while it is in the phone.