Razr won't boot, won't charge, won't recognize

EvanTheNotHuman

New Member
Joined
Sep 21, 2013
Messages
1
Reaction score
0
So I've got a Droid Razr, the original model. I've had it for a few months, two or three, not long. The battery has up to now been fine, if slightly short, but I've compensated for that with an external battery pack. About a week ago, it ran down and turned itself off, like it does usually. Only, when I plugged it into the wall, it wouldn't charge or boot. Now, I'm currently in Europe, so one would think the voltage might be the problem, but I checked and the charger accepts the voltage here. Plugged it into my computer, still won't charge, and the computer doesn't recognize that anything's been plugged into it. There's been no physical damage, no water, nothing that could have caused the failure that I know of.

So I left it for a few days on its own, thought maybe the battery was just having some problems with the heat here. I plugged it in today, and the white charging light came on when I jimmied the cable a little, but flickered when I tried to boot, and didn't boot or load the power level screen. Computer still won't recognize it, so it seems like nothing's changed. I tried following the hard reset instructions from this site, to no avail.

Anyways, as I said, I'm in Europe, and about 150 miles from the nearest store that could fix it, never mind the fact that the warranty isn't international. So I've got no way to have it fixed for cheap, and I'm out of ideas.

Any help is appreciated :) Thanks.
 
Back
Top