Razr M App Errors & System wont update from Android Version 4.1.2/System Version 98.18.78.XT907


New Member
May 7, 2015
Reaction score
Current Phone Model
Droid Razr M
Hey Everyone and Anyone,

I am in a state of complete frustration. I am not very good with electronic devices. So please bear with me and hold the technical terms or at least explain them for me if used.

I have a Droid Razr M that I have been using for about a year now. It was originally my older brother's phone that was passed down to me. It is still in great shape and it "was" doing what I wanted it to do for the most part.

My problem is as follows;

When I go to settings>device>storage is get a pop up error that says, "Unfortunately, com.motorola.huxvmm.setting has stopped." I hit "OK" and it then pops right back up. This all started after I uploaded music onto my phone without an external SD card, so it completely filled up my phones storage. When that happened I got an error that kept say something like "Storage space running out, some functions may not work." I then removed a bunch of apps I never use that my brother had previously uploaded as well as text messages and all my photos to free up space. That still didnt make the error message go away so I installed an 8GB MicroSD card. When I first put it in it said that the card was damaged and wouldnt accept it. Then finally it just asked to format the card which I did. Then that when I got the error, "Unfortunately, com.motorola.huxvmm.setting has stopped." I ignored the problem for a few days but kept noticing weird things like my app locations where moving around on the main screen and this past Sunday I had out of the blue an alarm go off at 3:57pm...which I NEVER set. Monday I headed straight for the Verizon store and they just said I need to do a hard reset/factory reset. I went home, downloaded cloud, and waited 36 hours for my phone to not even finish uploading all of my files. It got stuck at 92% uploaded. It kept saying no connection even though there was perfect Wifi at my house the whole time. So i just canceled it and cleared my phone anyways.

Here is my trouble shooting (in order):

-First I removed the SD card...nothing changes, still error code appears.

-Second I tried JUST the cache wipe...didnt work.

-Third I did the full system reset...error still appears

Then I called up verizon and they helped me troubleshoot it. Well come to find out my phone still has the System Version: 98.18.78.XT907.Verizon.en.US, and Model Version: 4.1.2. BUT when I hit System Updates it checks for a minute then I get a message that says, either "check for update is not available at this time. Try again later. OR "Your device is up to date! No update is necessary at this time.

The Verizon tech support attendant then connected her and I to a conference call with a Motorola tech support attendant. Basically they told me I need a new phone!?!?!?

After that I spent a countless number of hours searching online for a solution or someone else with the same problem. I didn't have any luck. Mainly because I am not so sure I want to get into a rooting procedure when I dont really know what it means nor does. If I had someone to guide me through it and it was a very possible fix, I would definitely consider it.

Also some other things I tried on my own were that I downloaded Device Manager on my PC. But all I got when I tried updating my phone via USB this message that said, "There are no updates for your device at this time. Current Version: N/A.

I feel the system never updated due to that is was in my brothers desk drawer, turned off for a couple years. Basically my goal here is to rid my phone of this bug as well as update the system to the newest version, 4.4 KitKat.

Please Help in any way that you can!!!