Phone locking up with BAMF Cubed 1.0.1


Nov 15, 2009
Reaction score
For a couple days after installing my phone locked up and froze at random intervals. I got annoyed with taking off the OtterBox to pull the battery so tried isolating the problem.

It doesn't seem to be management software. I disabled every feature (CPU rates, governor, voltage, perflock) of Antutu CPU Master individually and the lockup still happened even after completely uninstalling it. Same with Juice Defender. I tried reinstalling the ROM and kernel without a data wipe and the lockup still happened. I tried wiping the data and the lockup still happened. After about a day of testing, I seem to have found a combination of steps to solve the lock up. Wipe/factory reset, install ROM+Kernel, wipe user data (factory reset would also work). I have no idea what caused the lock up or why a second wipe was required for me. Log cat didn't show any critical errors, just a scrolling gralloc warning. If anyone is having the lockup issue and still wants to try the ROM (the ROM is definitely worth the time), I suggest trying a second wipe after installing the ROM.

Also, be careful about which system settings you restore from TiBu. I had some system apps crash after doing a settings restore. I eventually had to do a data wipe and restore only user apps (MMS was restored through SMS Backup & Restore in market).
Last edited: