PDAnet? Um...


New Member
Jun 1, 2011
Reaction score
So I've seen people ask a similar question, but none of the results seem to apply to my problem.

I have a Samsung Fascinate Galaxy S, I've only had it for about a week and a half now. The first time I tried running PDAnet, it worked awesome... for about twenty minutes. After only twenty minutes of usage, I got the error message that the disk had been ejected improperly, and my internet connection was severed. I don't understand what happened. Nothing was touched on my phone or the computer to make it seem not connected. The USB cable was still plugged into my phone, but upon further investigation, I found out that my USB Debugging had turned off for some unknown reason. It's been a week since I discovered this problem and I've tried a hard reset, a regular reset, I've tried fussing with the wifi and blue tooth, and I've even tried letting the mass storage program run, but it keeps disconnecting. What am I supposed to do? Having free tethering on this phone is my only option to have internet. Help me please!
Try another app - but most you'll have to scour the web for since the networks are blocking them.

I will try links later but can't atm but here are the names

Barnacle Wifi Tether for Android | AppBrain.com

android-wifi-tether - Wireless Tether for Root Users - Google Project Hosting my favorite

and also try updating to a newer version of pdanet should be 3.0 if on windows machine 2.5 i think on mac, i haven't set this up on my mac in a while but you can't get it off market nay longer so go to PdaNet -- USB Tether/Bluetooth DUN for Android

Best of luck getting on the interwebz and remember to clear out the lottery balls and horses the tubes are getting clogged. :blackdroid:
Thank you! But it's telling me i need root access, and I can't figure out how to root my phone using my mac. I don't have another computer to use... so I'm not really sure what to do. I found two places, but they want me to pay over ten dollars just to root my phone! What do I do? Do I have any choice but to have to pay for the rooting?