PDAnet Issue


Super Moderator
Oct 25, 2009
Reaction score
Tallahassee, Fl
I seem to be having a crazy issue with PDAnet, i can connect just fine, sometimes it's like a minute, sometimes it takes awhile but i get the following error, i've check google and only 1 other site seems to come up with it, but i've tried what they said to do and it didn't work. Which was to make sure that the SDcard was synced just in case, which they had an autosync .apk which works fine. Though no difference in the situation. It returns the following error:

Abnormal Disconnect: Read Header Returned Error (Code:31)

I have to completely get out of the program on my computer and get back into it or it locks the program up if i try to reconnect until i remove the USB cable, then gives me a c++ runtime library error. I have tried to reinstall the PDAnet version on my laptop, but gives me the same results.

EDITED: So far after the reinstall i don't get the runtime error anymore, but i still get the same disconnect.
OK so i found out what the problem was. The problem was a not so good USB cord. I had gotten 2 extra micro usb cords to use in my office and to have an extra if i needed it, and it was not as good quality as the cord that VZW gives you.

When using the micro usb cord given to you when you buy it, it works 100% of the time, when using the cord i had gotten as an extra it would only work about 10% of the time and even then it would only last about 10 minutes tops. So if anyone here runs into that issue, make sure you are trying it with the cord you get from VZW and MOTO.