One click root after update: "We have root, but couldn't push busybox. Not sure why!"


New Member
Dec 22, 2010
Reaction score
I just updated .890 which seemed to go fine with no errors (unfroze all bloat, but did not unroot), but I lost root, as expected.. but when I use Pete's one-click root tool (latest version), it gets to step 3 and gives me the error about not being able to push busybox...!? It says I "have root", but none of my apps recognize it.. I've pulled the battery, rebooted and retried like 10 times... still can't get it to re-root. Am I going to have to stock flash this thing and re-update & re-root?

*Edit* I do have some type of root.. maybe... because Root Explorer will let me mount the System directory as R/W and I can TRY to manipulate files, but if I delete something (like su), it appears to delete successfully, but the file comes back if I refresh the directory.. but I also noticed when I go into the System directory, Root Explorer claims I only have 1MB of free space out of 318.00MB... how did that happen? If I try to run Superuser.apk, it force closes on me.
Last edited:
I have the same problem. Step 3 either dies at su or busybox. I dled an app called root check and it says I don't have root even though the 1 click says i have root but can't push su or busy box. Not sure whats going on.
Did you re-check the usb debugging checkbox. Also you might need to check the "unknown sources" box. Settings-Applications & Settings-Applications-Developement

Just a thought
Yep, debugging is enabled and so is unknown sources... that's the first thing I checked /before/ trying to re-root right after the update... (and I'm set to USB Charge Mode)
I read around here once, someone said try toggling between charge and mass storage mode. Think it was in the 1root thread.

Sent from my DROID3 using DroidForums
Tried it in Mass Storage mode.. still same error... (and went back to Charge Mode and tried it again.. same error).
Don't know man.
Maybe down su from market and see if it will install that way.

Sent from my DROID3 using DroidForums
Yeah I did download SU from the market again.. it force closes!! ugh.. *beats head against wall*
OK, I got root back! I used steps 18+ for "ADB Method" (after doing Pete's temp ADB root) and essentially replaced SU and Superuser.apk, CHMOD'd it rebooted and I had root!

ADB Method here:

Motorola Droid 3 - RootzWiki
Last edited: