no email notification

New Kid

New Member
Dec 13, 2009
Reaction score
i have my gmail account synced and i do not get a notification for a new email untill i go into the gmail app and press refresh

how do i get it to notify me as soon as i get the email
If your GMail account is setup as your main account, go to:

Menu > Settings > Accounts & sync > GMail Account > Sync GMail

If that doesn't work go into the GMail app, Menu > Settings and make sure Notifications is checked.
thanks should auto sync be on or off?
thanks should auto sync be on or off?

To have the phone automatically go out and look for new mail on the server you need to have auto sync enabled, otherwise the phone isn't looking for the mail and you won't receive updates that you have new mail.

The reason why you are only getting the new emails when you refresh is probably because you don't have auto sync enabled, so when you click refresh you are sending the command to the phone to do a one time sync to check the server for the mail, thus updating your inbox with the new mail.
Auto Sync not working

I am having the same problem. All items listed are checked correctly, and Auto Sync is still not working. I have also done a reboot by pulling the battery and turning the phone back on.
Any more suggestions?

Are these labeled emails skipping the inbox, per chance? Because you won't get notified of those.
Auto Sync not working

These are business emails that used to sync, but now don't without a manual refresh.
I just sent a test message to myself from my corporate email account to my Hotmail account (forwarded to my Gmail account). The email is in my inbox on my Gmail account and no notification has reached my phone.
Auto Sync not working

The test message I sent to my Hotmail account did not reach my phone.
I sent a test message directly to my Gmail account and about 5 minutes later I received a notification on my Droid. When I opened the notification, both test emails were there.
Any ideas?