Droid keeps telling me I have new email when I don't

then it has to do with how you're synching messages. go into an account, click on settings and the labels. number of days to sync can be any number, but inbox and sent or whatever else needs to be more than 4 days. i have mine set to sync all and i have every message ever, from my gmail account.
 
then it has to do with how you're synching messages. go into an account, click on settings and the labels. number of days to sync can be any number, but inbox and sent or whatever else needs to be more than 4 days. i have mine set to sync all and i have every message ever, from my gmail account.

My settings are:

Duration-
Number of days to sync: 5 days

Labels-
Inbox: sync all
Sent: sync all
work email (non gmail): sync all

I've had those settings since I got the phone and the gmail account currently shows 41 emals in Inbox, but none are showing the the gmail app. When I check gmail on my Mac, I can see all 40 emails. I hit refresh a few times on the phone's gmail app and they still are not showing up.
 
then it has to do with how you're synching messages. go into an account, click on settings and the labels. number of days to sync can be any number, but inbox and sent or whatever else needs to be more than 4 days. i have mine set to sync all and i have every message ever, from my gmail account.

My settings are:

Duration-
Number of days to sync: 5 days

Labels-
Inbox: sync all
Sent: sync all
work email (non gmail): sync all

I've had those settings since I got the phone and the gmail account currently shows 41 emals in Inbox, but none are showing the the gmail app. When I check gmail on my Mac, I can see all 40 emails. I hit refresh a few times on the phone's gmail app and they still are not showing up.
well, you've got your bases covered, so that's good. and you say you see zero items in any of your three accounts, even though there are clearly emails online?
 
then it has to do with how you're synching messages. go into an account, click on settings and the labels. number of days to sync can be any number, but inbox and sent or whatever else needs to be more than 4 days. i have mine set to sync all and i have every message ever, from my gmail account.

My settings are:

Duration-
Number of days to sync: 5 days

Labels-
Inbox: sync all
Sent: sync all
work email (non gmail): sync all

I've had those settings since I got the phone and the gmail account currently shows 41 emals in Inbox, but none are showing the the gmail app. When I check gmail on my Mac, I can see all 40 emails. I hit refresh a few times on the phone's gmail app and they still are not showing up.
well, you've got your bases covered, so that's good. and you say you see zero items in any of your three accounts, even though there are clearly emails online?

Yup, and after a restart, I am getting "no connection", even after hitting refresh (but I still can browse the internet). I am on 3g. I am hoping there is something going on with gmail right now because this has never happened before.
 
when was the last time you rebooted and/or updated your PRL?
 
when was the last time you rebooted and/or updated your PRL?

I rebooted just a few minutes ago and it didn't help. What's strange is that my other gmail accounts are not saying "no connection". Unfortunately, the account that is not working is the main account that my phone is linked up with. To remove it, it says I would have to do a factory reset. Bleh.
 
i know it's a struggle, but a factory reset may be worth your time.
 
i know it's a struggle, but a factory reset may be worth your time.

I'm going to try a nandroid restore first and if that doesn't work, I guess I'll have to do a factory reset. Thanks for you help!
 
Last edited:
FWIW, i have three gmail accounts as well. one gmail account has about four POP3 accounts being checked, one has two and the other none. i've had no problems checking gmail or missed mails or whatever the case may be...

you might want to check that you don't have a desktop client somewhere that's deleting these emails (leave on server).
 
OK, I figured it out! I found this on a Google help page and it worked like a charm:

"1) Mine was directly related to the number of labels in my gmail account, how many of them I am syncing up, and how MUCH I am syncing for each label. I can reliably get this thing to fail into No Connection mode.
2) The fix is straight forward, a bit of a pain, but works every tome for me. Seems like a bug, which means I am hoping for a fix in a future update.

So, to get my "connection" back:

1) Go into the settings menu for the phone
2) Choose applications
3) Choose Manage Applications
4) Under Manage Applications set the Filter to ALL. Not sure why this isn't the default but c'est la vie.
5) Scroll down and choose GMail Storage
6) Tap the botton for Clear Data
7) Head on over into GMail and VOILA!"
 
google seems to like their quotas. simlar issue can happen with the calendar. it's all part of living in the cloud. the average user that only uses their phone as a phone will probably never notice these things.

nice find!
 
Back
Top