Need Help With Update 2.3.340! Adventure Story included!

Tjgrendel

New Member
Joined
Dec 11, 2010
Messages
19
Reaction score
0
This is my first post, I've finally decided to register after using this forum several times trying to figure issues I've run into while rooting.
So, here we go..

I have a droid x running the stock 2.3.15 from verizon. I got the droid x about a month or two ago. I rooted about 3 weeks ago. The only thing I did to it was install wireless tether. About 2 weeks ago my 16GB sd card died( ill get to that in a minute). Right now I have a 2GB in it now. Thats all the info about my phone.

Here's whats happened...

(Day 1)Sat by my phone all night, waited for that new update. As soon as it went up I downloaded it and installed. While it was installing it stoped 1/3 of the way through and reset. When it turned back on it said "Update Failed". So I thought the best thing to do would to unroot and uninstall my apps including super user. I used the one click root again, unrooted then while navigating in my phone deleted Super User. Reset/formatted my phone and sd card. Tried it again, no luck. Proceeded to wallow in sadness blah blah blah...

(day 2) When I woke up in a mess of my own tears and sadness I decided I would take my phone to verizon. (at this point I thought I was the most clever person in the world) (side note)When my sd card broke I took it to verizon and was like "Fix this!". My phone changed about 15 hands trying to firgure out what happened. (side note again!) I told them how I woke up one morning and said Sd broke blah blah blah never taken it out blah blah blah dont buy your sd cards from sweatshop B in china blah blah about 36 times so I was already irritated over 9000. Then they sad they can't fix it because the phone was rooted. I proceeded to say yes but the SD is not. There are two separate warrentys, long story short they refused I was pissed and left.(anyway) I took my phone to verizon (day two) (different store) and said the magic sd fairy broke my card, guess what? They gave me a new one! Why you might ask? Becasuse they could find no sign of my phone being rooted so now it was their problem! in your face verizon! Didnt say a word about the update problem. (although I am considering it)


(day 3)A few hours ago I tried the manual way. Found the .zip online then put it on my SD card and when I tried to update, it gave me Error 7, which for the life of me can't even firgure out what that means. Anyway my phone won't update and to my knowlege and verizons my phone is not rooted. However I can't exactly be certain. When I first rooted it i had some trouble with the one click root. I got pissed at it and just clicked the root and unroot like 9000 times in furry. When I did get it to root it literally took me 5 milliseconds to say F this and I clicked unroot. Funny after that it was still rooted. (I used a different one click root to unroot it)

(Android.day.3.535am) (today)Phone has been reformated and at this point I just want the update to work. I don't care how I just want it to work. 2gb SD card it in the phine now. I still dont trust that 16GB. So if anyone can help me please don't hesitate. If enough of you really want me to go back to verizon and see if they can fix it let me know. I wouldn't mind writing another story about it. At this point think of my phone as a canvas for your therories. Ill try anything you want! I don't even have a gmail account hooked up to the phone.

Thanks in advance for your comments! dancedroid

*UPDATE*
Got my Droid X Finally working thanks to sirdirk2

If you have the same problem as me just run through this thread!
Good luck!
 
Last edited:
I had to flash to android2.2.sbf, update, then re-root with z4root. Hope this helps. (Remember if you removed or renamed any stock apps you can't update until you get them back)

Sent from my DROIDX using DroidForums App
 
I haven't uninstalled any pre-installed apps.

But right now im stuck at the instalation process of rsd lite 4.8. I have a 64bit laptop (which im assuming is the problem) so its not letting me install it.

I won't have acess to a 32 bit computer for a few more hours.
 
Its quick and painless from here. Let us know the outcome. And search for z4root.apk if you want to root after the update
 
I doubt the 64 bit laptop is your problem. I have used RSD lite on both my Win 7 64 bit computers. The only problems I experienced were with using the proper Win drivers. It seems like Motorola keeps updating it's usb drivers. Also you have to find out what mode your usb will work in. Some people report varying results with different usb settings. Mine seemed to like usb mass storage. Also ensure that usb debugging is turned on. Good luck.


Geewiz2k1
 
Ok, the program says "Please manually power up this phone" "executed 100%" "in progress"

It is saying this while the phone is pluged in, I turned it off and back on. Its still pluged in. Same status. There is a blue triangle next to the bars and there is no network showing or phone number under settings. Whats next?
 
*228 to activate Verizon network. Choose option 1. Also check settings/about phone to see if your build is updated
 
Last edited:
Dialed *228, phone activated, I unpluged it, It works! trying update now!
Its downloading!
 
Boom! You are through the woods, updated, and up too early on a Saturday LOL
 
Boom! You are through the woods, updated, and up too early on a Saturday LOL
Hell Yeah it works! I owe you big time! Definatly saving all these files for furture use! Definatly rooting this! I've got two laptop screens to fix and 1 needs reformating. I wish I could go back to sleep! But people need their computers! lol

Thanks again! dancedroiddancedroiddancedroiddancedroiddancedroiddancedroiddancedroid
 
Much Appreciated

Hey SirDirk2

Just wanted to let ya know I appreciate the heads up on just reflashing stock to the original SBF. I proceeded with the OTA update lastnight and likje many others have experienced, I too found myself with the update failing around 30% and referencing the error to a problem with the build.prop and blur.

I've rooted my phone and installed various apps but never frozen or modified any original files yet I was still facing this dreaded error each time I tried something new to resolve it. Just taking your advice and flashing the SBF was actually the best route and less of a headache. I felt sure the flash would wipe my phone but to my surprise I still have everything still there. Widgets, live wallpapers, its all there. So I really just wanted to thank ya bro for your help.

I just recently made the last minute (and pretty nervous) switch from many years of my beloved Windows Mobile to the Android OS about 5 weeks ago and still filling things out but so far I gotta say I'm quite impressed with the OS. I was fairly known for various modifications and tweaks in the WM community so I look forward to gaining more experience with the Android OS and delivering some goods in the near future as I become a little more familiar with the new territory.

Again, thanks bro,
LivinXtreme2114
 
Back
Top