Motorola Droid Update Continues Through Sept 4

Interesting. I'm running metiCkOne's odexed rooted FRG22D, and continue to be getting all my Exchange email and calendar related goodies with no change at all to my Droid's login processes. It's like nothing changed anywhere.

And metiCkOne has made it very clear he left both FRG01B and FRG22D completely virgin with the exception of rooting, busyboxing and adding his name to the build (and deodexing with the deodexed version). The only major system level thing I have done is install a Chevy kernel.

I'm still convinced there has to be some feature, probaby for security, that my Exchange server doesn't have turned on, that FRG22D has this problem with. I've never used entry-security on my Droid, so perhaps it has something to do with that too.

I have to think, though, that Verizon is aware of this Exchange issue and is looking at it closely by now. It's affecting you and your institution very heavily, and it must be doing the same for others too.

Btw, I've never received FRG22D in either the patch or the full form as an OTA from Verizon. Perhaps still to come, perhaps not, because I'm using it already in the metiCkOne version???
While I don't doubt what metiCkOne has said, there has to be something else in metiCkOne's build that is different as this is happening to all our D1 users and it's not an exchange server active sync issue. I've created new sync policies, edited policies, removed all phones from the mailbox and have flashed my phone back to stock so many times it's getting sickening and it still has the same issue. But, this is all on exchange 2010, so it could be 2007 is different as I haven't tested that. I do know that 2003 doesn't support the phones so it's not an issue...

On a side note, from what I have heard, Moto is coming out with another patch to fix this in the next 30 days, so we'll see.

It is kind of fun trying to find a work around though, in a twisted sort of way :)
 
I can almost guarantee that the Exchage server at my work is *not* on 2010 yet. In fact it might not even be on 2007 yet. It serves about 10,000 people in a setting where being on the newest version and using the newest and/or strongest security is not the highest priority.

Not at all surprising about Verizon distributing another patch, I was wondering if that would be happening. I was even wondering if perhaps that's why I hadn't received FRG22D yet; maybe in Verizon's point of view, the patch for this fix will replace FRG22D. We'll see how this pans out...
 
I may have a fix. Today I flashed my phone back to stock and let the OTA update get me to FRG22D. On exchange 2010 I created a new active sync policy that has the following, "Allow non-provisioned phones" is NOT selected. And password required is NOT selected.

I then removed my phone from the OWA client. After that I created the exchange account on my phone and it still asked to be activated, but no password/pin required and all the security settings are no longer grayed out. I've power cycled my phone several times and it still seems to be working.

I'll be testing this on other users phone shortly.
 
Great, this is newsworthy stuff, I'm anxious to hear your observations as you deploy this fix.

Granted, not everyone is using Exchange with their Droid1s, but for those that are, they are probably in groups related to the business they are involved with, and those groups could be, as in your case and mine, extremely large. So the number of people potentially affected where this issue arises could be extremely large too...

With that kind of impact, I'd guess that Verizon, Moto and Google have to be watching this.

Here's an interesting question: Do any other Froyo phones have this issue?
 
I haven't tested the D2 yet and the X doesn't seem to be affected. We only have one person that I know of that has one and I can't get a hold of him yet.

So far, I've done about a dozen phones and every one of them works now. No more forced password.

One word of caution would be to only use this active sync policy for people you know. This should not be a default policy. You wouldn't want some random rogue oddball phone trying to sync. So just add the newly created policy to known users.
 
I haven't tested the D2 yet and the X doesn't seem to be affected. We only have one person that I know of that has one and I can't get a hold of him yet.

So far, I've done about a dozen phones and every one of them works now. No more forced password.

One word of caution would be to only use this active sync policy for people you know. This should not be a default policy. You wouldn't want some random rogue oddball phone trying to sync. So just add the newly created policy to known users.

I tried this with the D2 just a moment ago to no avail. I did not set the phone to factory defaults, but I was able to select whatever security I wanted after remove the corporate account. I was hoping I had read something wrong, but I have every setting described above. Bravo on finding a fix for D1, but D2 is still hosed.

I set the policy exactly as you describe and added it to myself. When I added my corp account, it asked for a pin..... I honestly don't think that Moto, VZ, or Android really know what is going on here. Bottom line though (Somebody else said this first) this is the first time since I've had a droid that I've regretted it. Makes the phone obnoxious to use.
 
Ah bummer. I'll see if I can get my hands on a D2 to do some more testing. There's gotta be a way around it like for the D1. I just did a few more D1's today and they are happy campers again. And i didn't reset them to factory defaults, I left them as is.

I'm sure you checked, but make sure after your exchange account is removed from the phone and the password/pin is set to none that you log into owa from a computer and delete all instances of your phone under the options/phone setting. And give the active sync policy change in exchange console a few minutes to replicate out.

I know how you feel, it's very frustrating.
 
Ah bummer. I'll see if I can get my hands on a D2 to do some more testing. There's gotta be a way around it like for the D1. I just did a few more D1's today and they are happy campers again. And i didn't reset them to factory defaults, I left them as is.

I'm sure you checked, but make sure after your exchange account is removed from the phone and the password/pin is set to none that you log into owa from a computer and delete all instances of your phone under the options/phone setting. And give the active sync policy change in exchange console a few minutes to replicate out.

I know how you feel, it's very frustrating.

So I actually forgot to remove the instances of my phone through OWA, or Exchange, but I tried again this morning and it still didn't have any effect.
 
Wondering what, if anything, 2.2 being available for the Droid X means for us who haven't received the update on our Droid 1 yet?
 
I'm in L.A. and the update is available for my Droid X :) Will do it when I'm home later.
 
Wondering what, if anything, 2.2 being available for the Droid X means for us who haven't received the update on our Droid 1 yet?

You should go get the large file FRG22D build and manually install it. Or take it into a Verizon Company store. Easier to do yourself. Chris
 
Wondering what, if anything, 2.2 being available for the Droid X means for us who haven't received the update on our Droid 1 yet?

You should go get the large file FRG22D build and manually install it. Or take it into a Verizon Company store. Easier to do yourself. Chris

I tried to download it and it didn't take. Got the error message.

But the question I have is why did they not get it out to all Droid owners? Yet they seemed to have moved on and are now getting it to X owners.
 
Back
Top