Interesting Find (Google Wallet Involved)


Nov 8, 2010
Reaction score
Okay, so I've been having some issues with my phone, so I decided to go back to Stock [root]. I had a backup from before I installed CleanRom 6 a while ago, so I tried to install it. It worked, but I couldn't get past the "Samsung Galaxy SIII" screen. So I went back into Recovery, and did a full system restore, and cleared the cache, started fresh. It let me boot the phone, and went through all the initial setup crap, and I had NONE of my apps from before.So that was the background story. Here's the interesting part..... Google Wallet is now installed on my phone.... and I didn't put it there. I'm trying to set it up, and it's saying "Google Wallet cannot start until your phone is fully initialized."Has anyone else tried to go back to stock recently, and has Wallet just magically appeared on your phone as well? Maybe Verizon really ISN'T blocking it anymore...... Might be worth checking out.
I'm 100% stock. Google Play reports the app is "installed", but when you click on it, it clearly states the app is not available for the device.
That's really strange. The app showed up in my app drawer, and when I clicked it, it just wouldn't go all the way through the setup process. Said it could not fully initialize or some garbage like that. But it didn't give me the option to uninstall it either, so that was weird.