Galaxy SIII MSO365 Calendar Sync


New Member
Apr 23, 2011
Reaction score
I have been a user of MS 365 since last Feb for work e-mail and I liked it so much I signed up for my personal e-mail in July as well. It has been working very well.
For My work E-mail and Calendar, and Contacts I use TouchDown and it works great, love that app.

In January I replaced my Motorola DroidPro phone (Android Version 2.3.4) with a Galaxy SIII (Android Version 4.1.1)[Pic N01]. I set up MS365 account on the phone using the default e-mail and calendar apps, as a “Microsoft Exchange ActiveSync” [Pic N02] account and asked that it sync my E-mail and calendar [Pic N03]. I have the “Sync Schedule” set to “Push” for both “peak and “Off-peak” times[Pic N04]. This is the same way I have and had my DroidPro setup before I stopped using that as a phone. I still have it set up as WiFi only device.

I receive and send e-mails on my Galaxy SIII no problem, I see them on both the phone and my computer (using Outlook 2007) What is happing differently on the SIII as compared to the DroidPro is when I read an e-mail on the phone and then download it on to my computer, it is not marked as already read. That is not a big deal.

The other, much bigger deal is if I add something to my Calendar in either place, the SIII or Outlook it doesn’t show up in the other, or if I edit something on either device the other is not updated. But all of the change I make on the DroidPro or in Outlook show up in both the Outlook and the DroidPro. I hope I didn’t confuse you recap:
Calendar changes:
Using SIII, add or edit something it only shows in the SIII, not in Outlook or DroidPro
Using Outlook, add or edit something it shows in Outlook and DroidPro but SIII doesn’t show the changes
Using DroidPro, add or edit something it shows in Outlook and DroidPro but SIII doesn’t show the changes

Now if I go into “Settings => “Accounts” => “Microsoft Exchange ActiveSync” => and look at my account it says “Sync disabled”. How do I “enable” sync? [Pic N05]

Then if I tap on that it shows me when the Calendar and E-Mail were last synced [Pic N06]. The calendar is true but the E-Mail is not because I have received e-mail more recently than when this says.
Then if I tap on “Sync Now” the Calendar syncs up perfectly [Pic N07].

Do you have any suggestion on how to get the calendars to sync in both directions with a Galaxy SIII, when I change is made? I don’t feel I should have go in a press sync every time to make show the SIII is up to date.

All Screen shots are on the this link:

Any help you can provide would be greatly appreciated.

Thank You in advance for you time helping me trouble shoot this.