Force WiFi Calling

Sajo

Diamond Member
Joined
Jan 25, 2013
Messages
20,817
Reaction score
16,981
Location
Tennessee
Current Phone Model
Pixel 7 Pro
Good morning folks. I figured I would ask here since we have a large group of folks using different phone models. I travel a lot for work. The new area I will be traveling to quite often has horrible cell signal. Almost nothing at all, no Data and very weak basic phone signal. I know, I know that's crazy in a densely populated area in 2017; but the locals are working petitions to get more cell towers in the area. The hotel I will be staying at has excellent WiFi and my phone is WiFi calling enabled; with WiFi calling turned on & configured (Moto Z Force Droid). On my previous phone (Droid Turbo 2) I could put the phone in Airplane Mode and then manually turn on WiFi and make a phone call; the call would connect using WiFi calling. On my current phone when I tried that I received a pop-up message stating that "calls cannot be made in Airplane Mode, would you like to open Airplane Mode Settings?". Or something very similar to that. All of that leads me to my question, with these newer phones is there a way to force WiFi calling?

I read a lot of Verizon Support topics and they all state that if there is any cell connection at all the call will always go out over cell. I ended up using Hangouts Video calling over WiFi, which works OK. But I'm trying to figure out if I can force WiFi calling, and if this new "feature" of not being able to use it in Airplane Mode is a Moto thing or a new Verizon thing. Thanks.

Sent from my XT1650 using Tapatalk
 
Still works for me, Sajo, see attached. Yes, I then made a call over wifi.

0fa96f6ac1cf0c5f81e53c3e0ab8d2cd.jpg


Sent from my Moto Z (2) using Tapatalk
 
Last edited:
Thanks Pere! . I have been experimenting with all of my Settings since reading your post. I even turned WiFi calling off, rebooted, set it up again, etc and still can't force my phone to make a call on WiFi. I may have to try a FDR before my next trip, I'm starting to think my Advance Calling / WiFi Calling functionality is messed up. I have not done a FDR on this in the year I have owned it and have upgraded the Android OS three times and upgraded numerous System Version updates.

Sent from my XT1650 using Tapatalk
 
Thanks Pere! . I have been experimenting with all of my Settings since reading your post. I even turned WiFi calling off, rebooted, set it up again, etc and still can't force my phone to make a call on WiFi. I may have to try a FDR before my next trip, I'm starting to think my Advance Calling / WiFi Calling functionality is messed up. I have not done a FDR on this in the year I have owned it and have upgraded the Android OS three times and upgraded numerous System Version updates.

Sent from my XT1650 using Tapatalk
Well thank you for telling me this. I never know you could turn on Airplane Mode and then turn on just WiFi. That's really cool.

Sent from my Moto Z (2) using Tapatalk
 
Just for grins I just tried airplane mode plus Wifi on and Wifi calling worked just fine on my Pix2?? Sorry to hear you're having trouble Sajo.
 
Thanks for the confirmation radon.

Sent from my XT1650 using Tapatalk
 
Thanks for the confirmation radon.

Sent from my XT1650 using Tapatalk
Worked on my z2 force

Sent from my Moto Z (2) using Tapatalk
 
Thanks for the confirmation radon.

Sent from my XT1650 using Tapatalk
I was just reading up that if you have WiFi calling supported by your carrier and turned on then apps that support WiFi texting can send and receive texts not sure about limitations about mms or to iPhones .
It seems Google messages started supporting it once project file started even if you don't use project FI

Sent from my Moto Z (2) using Tapatalk
 
Back
Top