Email connection to Exchange


New Member
Dec 8, 2009
Reaction score
Unable to connect Email App to Exchange

I've had my droid since December. When I got it, I was able to connect to my Exchange 2003 OWA and pull all my email flawlessly. Things worked great. My company does NOT support Activesync.

I since have gotten the 2.01 OTA update, and for some reason, I cannot get my corporate email to work anymore. I stopped getting messages right after the update. I can browse to the corporate OWA from a browser on the phone and login just fine.

I've been through the setup wizard *many* times and after putting in my information, I get "unable to open connection to server". If I put in the wrong password or username in the email app, I get a different message stating that my credentials are wrong. To me that means I'm getting to the server, but I cannot fully connect. Others in my office with DROIDS are still working fine using 2.01. My wife got a new droid this week, and I was not able to connect with her *new* phone either. I get the same error messages. I've also changed roms several times with no change in ability to connect.

Any ideas on how to fix? This is a major issue for me as it was the primary impetus for getting this phone.
fyi - I have done many searches both within this forum and via google to no avail.

I have a Moto Droid and was having the same problem. Spent about $23 to download Touchdown and now it works GREAT!