Droid X locking up only when screen is off.


Dec 3, 2010
Reaction score
I had this issue a long time ago on I believe all gummyjar kernal based roms such as liberty and gummyjar. I would have to go back to stock or to a different rom such as ApeX etc. I know this was an issue for others and used to talk to a large number of people who had the same issue on those roms. It tended to happen when trying to wake the phone and turn the screen on, or when turning the screen off. The phone would freeze with a black screen and become completely unresponsive. The notification LED would still flash, but you would be unable to unlock phone unless you did a battery pull.

I am now having this issue on stock gingerbread. It is a little different now in that now it happens typically when im listening to music or a podcast, as that is what I use my phone for 99% of the time. What im listening to will cut off, and I will be unable to wake the phone. the notification lights will continue to blink, but still unable to unlock it. At times it seems to be related to having it plugged into my car charger. I've noticed that sometimes when it happens is when my phone makes a sound to notify me its now charged. Though, It can also happen when im not plugged in or charging at all.

I have tried SBFing 2 to 3 times, and have have tried to install CM7 2-3 times and it will not stick. I get stuck in a bootloop each time even though all of the checksums are matching and everything should work. I have installed 100s of roms in the past, so I am very familiar with the entire process. I have been out of the loop since gingerbread came out and have stuck with it for the most part. However, I believe when my major issues started was when I changed from the leaked versions of GB to the actual SBF stock versions. I swapped from the leaked version because I was having the same issues, just at a much less rate. The phone functioned well, but suffered from occasional freezing. Now since I went to stock SBF it has made the issue 10 times worse. It just has not worked right since, my phone is slow and sluggish and just infuriates me at times. I rooted with the tethered root after I SBFed and it just seemed odd. When my phone reboots, I am stuck in a very laggy state for about 3-5 minutes. Everything is unresponsive and just will not work correctly. After 3-5 minutes, bootstrapper will finally get root permissions and the phone will start to function. This is odd to me as it used to happen immediately on boot up. Another oddity is my file system just seems completely odd. For some reason my internal memory or being duplicated for my external SD card. I have no more download folder or anything of that nature. I have tried multiple different file system and it just makes no sense. I go into SDcard and the items there will be the exact same as if I go to my internal memory storage. It's not that i'm unfamiliar with the file system, as I used to go in and make manual edits using metamorph or other similar programs.

Does anyone have any suggestions here? I don't care if i'm stock, if I can just get my phone to function properly. I would like to try CM7, but realize with my issues it may not happen.