DROID RAZR MAXX HD - Screen Issues

DanielF823

New Member
Joined
Oct 25, 2012
Messages
1
Reaction score
0
I am in love with this phone!!!

I got an Iphone 5 on release date (and only waited 15 minutes by going to a corporate Verizon store that isn't very well known) and returned it within 10 days because the battery life sucked, the interface too restrictive and everything else that drives people away.

That's beside the point, the other day I was woken up by my alarm clock but it was purple and dark... WTF?!?! I clicked the power/screen off button and when i pressed it again the screen was normal again.

I ignored it in hope that I wouldn't have to do another 4-5 hour process of getting all of my apps, layouts and settings to where they were...

But today it happened again!!!!

It's just a really weird purple tint over the screen... I have fixed enough phones and computers in my day to know that's a glitch (or connection problem) in the display connection or screen controller... I haven't even dropped this phone yet ;-P

Anyways I just wanted to see if there are others with this issue as well?
 

YankInDaSouth

Theme Developer
Theme Developer
Joined
Jul 8, 2010
Messages
3,186
Reaction score
369
Location
Sharpsburg, GA
Website
www.wix.com
I have not seen nor heard of this ... sadly it seems like you've got a faulty device. Sounds like you may need a replacement ...
 

94lt1

Super Moderator
Staff member
Premium Member
Joined
Jan 16, 2012
Messages
17,048
Reaction score
4,014
Location
SE TX
Current Phone Model
Droid Turbo 2
Tap on clock in your apps tray... it brings this up.... this is a night screen so you can sleep without a bright light... I think.
 

Kaos2flo

Member
Joined
Mar 13, 2010
Messages
264
Reaction score
4
Location
Tampa, FL
I don't want to hear about any issues!! Lol. So far, the phone is sooooo perfect to me!
 

bman6074

Member
Joined
Nov 5, 2012
Messages
46
Reaction score
0
I had this problem and too ignored the first couple times but then it happened a total of 4 times. I was finally able to grab the camera and get a good pic of it to show the people at best buy where i bought the phone. They looked at the photo that i transferred to my phone and could see my icons through the bluish purple screen in the to validate it was my phone and not another pic from the internet. I explained that i read about 3 others online who reported the issue and someone mentioned it could be a video memory issue (hardware). I also had GPS lock issue too. So they replaced with a new one. I had only had it 15 days so i was within the 30 days. They said after 30 days i would have to go through the manufacture. So far new phone seems good at least as far as GPS is concerned. We will see about the screen (only have the new phone 1 day). If your having this problem i would recommend getting a photo and taking back to the store for a replacement. I think some of the earlier phones may have build issues which is not unheard of with a new product.
Hope this helps others with this issue
View attachment 58225
 
Top