Droid 2 wont boot after installing unleashed 2.7 rom


New Member
Oct 4, 2010
Reaction score
I decided today to root and install a custom rom on my phone (D2). I reset my phone to factory settings and then rooted using a 1-click root method and proceeded to install the unleashed rom. I transfered the .zip rom to my SD card, installed the rom manager and flashed the clockworkmod recovery and booted to recovery. everything was working fine, i went through all the steps in the guide from theunlockr.com and when it said complete i hit ok to reboot. Now my phone will not boot passed the "Droid" animation after the M logo. I can't restart unless I take the battery out and I cant get it to boot up normal. I also tried to but it in recovery which didnt work. I tried wiping data/factory reset, wipe cash partition and apply sdcard:update.zip with no luck. It seems like the clockworkmod recovery is gone.
Can anyone help/guide me to help fix my phone.
also to note: on the bottom of the recovery screen it says E:Can't open /cache/recovery/command
ok thanks. I figured out how to use the RSDlight and .sbf but my phone died while I was flashing it so now i get a bootloader that says:


Service Req'd
Battery Low
Cannot Program
if you can charge your battery on another droid or get a friends battery you can retry it.