Contacts added from phone not showing up


Dec 18, 2009
Reaction score
Fixed: Contacts added from phone not showing up

I've tried searching about this, there's many threads about this but not specific to the problem I'm having that I was able to find.

Since I got the droid I've done the following steps relating to my contacts:
  1. Exported from Verizon website to .csv
  2. Imported to my gmail account on a computer to a group I created called "Import"
  3. Synced my Droid with my Gmail account and it picked up all my contacts I imported.
  4. Selected on the Droid to "Only show contacts with Phone Numbers"
  5. Created a contact through my Droid, called "test" with a 10-digit phone number.
    1. "test" doesn't show up anywhere in the Droid contact list
    2. If I search for "test" on my droid it doesn't show up
    3. If I search for "test" on my gmail account from a PC it shows up under "Other Contacts"
  6. I have the following Display options on my Droid selected:
    1. Only Contacts with phones
    2. Under my Gmail account heading I have check marked: "System Group: My Contacts", "Starred in Android"
    3. I don't see "Other Contacts" anywhere on the Droid. On my Gmail account I can only see this "Other Contacts" heading when searching for "test". It doesn't show up as a legit group on the left hand side of the Contacts section of gmail.
    4. Under More Groups I have the options: "System Group: My Contacts" (again??), "All Other Contacts"
  7. In an attempt to get "test" to show up on the Droid, I tried selecting "All Other Contacts". When I do this it adds "All Other Contacts" without a checkmark, but it also adds the second "System Group: My Contacts" with a checkmark. If I checkmark "All Other Contacts" and hit done I get a "The process android.process.acore has stopped unexpectedly. Please try again." crash. This happens whether the second "System Group: My Contacts" is selected or not.
  8. I've performed the following steps as suggested on another forum to try to fix this:
    1. Move all imported contacts through Gmail to "My Contacts" and deleted the "Import" group. This "My Contacts" never shows up on my Droid, only "System Group: My Contacts". Both of these show up on Gmail. "My Contacts" has 99 entries, while "System Group: My Contacts" has 97.
    2. On Droid, Contacts shows 96 entries.
The only way to get a contact I created on my Droid to show up on my phone was go to my gmail account, do a search and find it, and manually move it to "My Contacts"


Fixed: I finally solved this by doing a factory reset/format. Once I ensured my Gmail contacts were setup the way I wanted: no extra groups, have all my phone contacts in "My Contacts". I did a factory reset, synced back to my Gmail account and it picked everything up correctly and was able to create contacts from my phone and have them show up in my phone right away without an issue.
Last edited:
Have you tried unchecking the "only contacts with phones" and checking every option to display everything? Then try unchecking the stuff you dont want and see where the problem arises?

As for the numbers not adding up, could be the droid merging contacts if you have duplicates.
That may work but I'm still looking for a straightfoward solution. The issue with this approach is that everytime I get a regular email contact it will get added on my phone and ill have to manually remove it..

Edit: I just tried this. Once I add all other contacts, whether I checkmark it or not, and hit done I get the acore process crash.
Last edited: