black screen


New Member
Jan 12, 2011
Reaction score
My phone has been rooted simply for the fact of needing a wi-fi hotspot. I have the original droid bought on 10/10. Last night, I was trying to get a custom rom on my Droid, because I noticed that moving in-between the menus on my stock droids firmware was near impossible.

So I installed RomManager, and tried to install smokedGlass on my Droid. It didn't work the first time and had to recover it via clockworkmod. I still have these recoveries on my SD card.

Now, I tried it again when I got home for the night. I downloaded the rom via RomManager, and now when I power it on, it shows me the motorola logo, with nothing more. You can see that the screen is backlit, and the phone has power to it.

So, basically, I have no access to any phone apps, no idea weather or not I received texts or missed calls, and cannot access any of my flashes to restore. The phone powers up and the ONLY thing I am able to do is go into android system recovery. Nothing more nothing less. If I don't hold power and x, the screen stays a steady black.

What are my options here? I have tried restoring, but to no avail. Also, When I hold the powerbutton + x, it does NOT show up with clockworkmod, just android system recovery.

I cannot get into clockwork recovery...I have flashed my images to restore, but cannot restore due to the fact when holding powerbutton + x i get android system recovery.

My laptop I am typing on right now has an SD port, as well as having the ability to put my Micro SD on my laptop, and do things that way.

I went to verizon already. They are sending me a new droid tomorrow, but I would much rather get my old droid working again if possible.