Android webview doesn't work properly on 4.1.2 device but works perfect on 4.0.4


New Member
Oct 22, 2014
Reaction score
I have Geniatech ATV520 Enjoy TV Dual Core Nono and Geniatech ATV310B-Enjoy TV Nano devices,
and I wanted to add my own webview on them. The problem is that the webview on 520 device is leaking and it isn't the problem in the code, because I have tried everything from a simple webview to a more complex one, destroying whole activities and restarting them, loading different pages and I even tried to add Chromium webview from github which works fine for a few days then crashes. On newer device it looks like it is getting some memory leak each 5-10min and it doesn't clear memory usage, but on older one it just keeps jumping from 18-25Mb like it should.
The problem is I cannot get webview to work normally on 520 device which has 4.1.2 android version, but on 310b which has 4.0.4 they all work ok, even basic android webview. I also tried to run it on my phone which has 4.2.2 and it works normally. The only difference from a software point of view is Android version and a different firmware. Does anyone have any suggestions or a clue on what could be done, because I didn't find any possibility to upgrade this new device or downgrade it if that would help?