wireless tether after root

Discussion in 'Droid Incredible Hacks' started by mich1248, Dec 6, 2010.

  1. mich1248
    Offline

    mich1248 New Member

    Joined:
    Jan 10, 2010
    Messages:
    78
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Charlotte NC
    i just rooted my incredible and want to use the wireless tether app i downloaded from the market..i install the app and press the green wifi button, and the connect it to my laptop..they connect fine but just a local connection, no internet...i do this same procedure on my droid x and my droid1 and connects to the internet just fine..why am i having problems with the incredible..any suggestions?
  2. dankarlinski
    Online

    dankarlinski Guest

    do you have SU installed? lets start with that


    if you do, go into SU and delete the wireless tether "profile" try to load up the tether again and see what happens.



    also, in tether, hit menu and access control. enable access control and then allow it on your device. i am not entirely sure what access control actually is/means/does, but it fixed my problem with i had one.
  3. jsuh
    Offline

    jsuh New Member

    Joined:
    Oct 8, 2010
    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    0
    The one provided on the market does not work properly; it is outdated.

    You can find the latest version at Downloads - android-wifi-tether - Project Hosting on Google Code Uninstall the current version you have; then download and install the latest version at that link.

    That will fix the problem you have.
  4. BCool83
    Offline

    BCool83 New Member

    Joined:
    Sep 29, 2010
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    0
    I have the most up to date version, and tried both of dan's suggestions, and still have only local connectivity. Using a Droid X, but still...
  5. jsuh
    Offline

    jsuh New Member

    Joined:
    Oct 8, 2010
    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    0
    When you say you downloaded the latest version, I mention that because the market version doesn't work. You need the 2.0.5 pre-14 or pre-15 version that is not on the market.

    1. Go to Settings > Applications > Manage applications > Wireless Tether
    2. Clear data and click uninstall.
    3. Download Wireless Tether 2.0.5 pre-15 at: wireless_tether_2_0_5-pre15.apk - android-wifi-tether - Wireless Tether for Root Users 2.0.5-pre15 *** EXPERIMENTAL *** - Project Hosting on Google Code
    4. Install Wireless Tether 2.0.5 pre-15.
    5. Open Wireless Tether
    6. Menu softkey > Settings
    7. Check "Enable Access Control"
    8. Go back and press the green button to start wireless.
    If that still doesn't work, what ROM are you running? Did you flash a custom kernel? I suggest going back to a stock kernel if you did.
  6. BCool83
    Offline

    BCool83 New Member

    Joined:
    Sep 29, 2010
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    0
    Sorry if I misspoke - but I haven't DL'd a version from the market since the very first one I tried (probably PRE9). I've since tried every version from Project Hosting up to PRE15, which is currently installed.

    I've tried with and w/o Access Control enabled. Still get Local-only connection.
  7. jsuh
    Offline

    jsuh New Member

    Joined:
    Oct 8, 2010
    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    0
    Did you flash a custom kernel? If it wouldn't hurt you, try flashing a stock kernel.
  8. BCool83
    Offline

    BCool83 New Member

    Joined:
    Sep 29, 2010
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    0
    No, actually no one suggested that until I saw another thread on another forum about the same problem, but on an HTC Evo. I have no idea how to flash a stock or custom kernel...have to do some searching I guess...

    EDIT: A brief search seems to say that the DX kernel (though I still don't know what it is) can't be changed?
  9. jsuh
    Offline

    jsuh New Member

    Joined:
    Oct 8, 2010
    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    0
    Yeah, if you have a custom ROM, sometimes it's built in with a different kernel. Reason why I ask is I remember that the kernel has to be net filter enabled.

    I wish I could help you more, but I don't own an X. Maybe head over to their section for more help.
  10. Hashi
    Offline

    Hashi New Member

    Joined:
    Apr 16, 2010
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    0
    This may be the "blind leading the blind" (since I don't have an incredible yet), but '"no internet" could mean a lot of things, like no DNS, inside access, but no outside access, no outside->inside , all of which had different solutions.

    Here's a few things you could try: I looked over at the site you're getting wireless tether from and they've got a wiki and I've not seen it mentioned in this thread so check this 'incredible-specific' bit of it out:

    Setup_HTC_Desire_Incredible - android-wifi-tether - Setup Howto for HTC Desire, HTC Incredible, HTC Aria, HTC Wildfire - Project Hosting on Google Code

    It basically says the requirement for the incredible is different than the droid, (on which I've been running an old version of this without issue for awhile), and that you need to create a folder on the /sdcard, "android.tether". and download a file, fw_bcm4329.bin and put it in there.

    Well, you can read that and I hope it helps.

    The other thing(s) are just to narrow down the field if you've got a terminal emulator installed: --

    If you can $ ping URL's/IP's then first try an outside IP (a public facing IP, as you'd get back from doing an $nslookup google.com or some such URL):

    $ ping 4.2.2.1 (I think this is opendns.org)

    If you can reach it, then your problem is DNS. There are several "setProp" and getProp commands you can use to clear this up on a droid, but at least you'd know how to report the issue if you could hit that address.

    If you can't reach it, it could be a gateway problem (using an internal gateway for the 3G network operations). I'm just going to guess that the wireless tether code is OK because I've used it successfully a lot with WEP, without, and with & without access control. Sure, maybe there's an incompatibility with the incredible, like a missing module, but I think we'd have heard a lot more about something obvious like that.

    What happens when you ping google.com? Does it get the DNS, and say, "no response from "ww.xx.yy.zz" (or whatever 5 IPs google.com uses these days)? If it is doing the DNS then the gateway is probably incorrect. Again, I think there's a 'droid' "setProp" way to change that, but it would just be more useful to file the bug correctly.

    Anyway -- I hope something in here is of use. I'll probably either be in the same boat when I get one ;) or else I'll figure it out and let you know or someone else will let us both know. I hope so because it is my favorite feature of these phones.

    Hashi

    Edit:: I was just changing some of these settings I mentioned from Term Emulator on my droid, and thought I'd put examples in:

    The ones I think matter are these:

    { $ su
    #bash
    # getprop | grep dns
    dhcp.tiwlan0.dns1
    dhcp.tiwlan0.dns2
    net.dns1
    net.dns2
    }

    When attached to wifi, these may show non-routable local addresses like 192.168.x.x (address of your wifi router)
    When attached to tiwlan0 (3g) the may show public facing IPs like 72.34.xx.yy.

    You can set them using setProp dhcp.tiwlan0.dns1 x.y.z.z

    Oh yeah: There is also one for the gateway(s): like getProp dhcp.tiwlan0.gateway will return the current 3g gateway if 3g is in use.
    etc.
  11. BCool83
    Offline

    BCool83 New Member

    Joined:
    Sep 29, 2010
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    0
    Check that your computer is not configured to just one static IP address - you want the comp to detect an IP addy automatically.
  12. dankarlinski
    Online

    dankarlinski Guest

    an easier way is to download the fission rom manager lite from the team defuze site. you can download the patch for the stock 3g hotspot app. verizon will never see you are using it. thats what i am currently using instead of wireless tether
  13. jntdroid
    Offline

    jntdroid DF Super Moderator Premium Member

    Joined:
    Nov 18, 2009
    Messages:
    6,437
    Likes Received:
    292
    Trophy Points:
    83
    Location:
    TX
    I'm having this problem as well... tried every version of WTFRU, plus Barnacle, and it either won't connect or it does like the OP says. I'm simply rooted (unrevoked/s-off), no custom ROM or anything. The stock kernel supports wifi tether, does it not? I guess I could try flashing a custom kernel, but I was hoping to avoid that... plus, I'm very new to the Dinc world, so I'm still getting a feel for the different kernels, etc., that are available...
  14. enlightened
    Offline

    enlightened DF Super Moderator

    Joined:
    Sep 6, 2010
    Messages:
    1,074
    Likes Received:
    4
    Trophy Points:
    0
    Location:
    NYC
    Thank Doug Piston for this solution:

    First step is root. Then download android wireless tether from the market. Next step would be to make a folder on the root of your sd called android.tether then put this .bin file in it.

    fw_bcm4329.bin

    Final step.. start tethering
  15. jntdroid
    Offline

    jntdroid DF Super Moderator Premium Member

    Joined:
    Nov 18, 2009
    Messages:
    6,437
    Likes Received:
    292
    Trophy Points:
    83
    Location:
    TX
    good ol' DP! thanks for being the messenger :)
Search tags for this page

how to tether after root