Wifi not working well with D-Link 4500

Discussion in 'Android Tech Support' started by slalomx, Feb 26, 2010.

  1. slalomx
    Offline

    slalomx New Member

    Joined:
    Feb 26, 2010
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    0
    Set up a new D-Link 4500 router, running it at 2.4 Ghz and WAP security. Seems to be working fine with my laptops, but is not working well with my Droid. It connects fine, but there is a communication problem as pages will barely load and time out. I used one of the Speed Test apps, and once it finally starts going, the download and up speed are great. The problem seems to be in the latency/ping. Right now trying to use Wifi is useless because everything just hangs. Is there a known issue with Wifi and D-link or a particular security setting like WAP?
  2. huskur
    Offline

    huskur Well-Known Member

    Joined:
    Dec 3, 2009
    Messages:
    1,870
    Likes Received:
    33
    Trophy Points:
    48
    Location:
    Lower Delaware
    First things first.....if it is a new router make sure you are broadcasting in "G" and not "N". I have a d-link router that will broadcast in both "N and G bands" (you can check this in the routers webpage, i think for d-link it is 192.168.0.1)

    2nd...this usually will fix the issue. You need to unplug the router and let it sit without power for about 30 seconds and then boot it back up and it will "refresh" its settings. 9 out of 10 times this solves the issue

    also, within the router webpage you should be able to set up guest access. It will connect automatically and easier if you use that.
Search tags for this page
d-link android problem
,
d-link not supporting wifi
,
d-link wifi not turning on
,

d'link android wifi problem

,
dlink wifi not connecting
,

dlink wifi problem

,
problems with my d link on wi fi
,
why is wifi not working well
,
wifi is not working as well
,
wifi not showing on my d-link