What have YOU done with Tasker?

Discussion in 'Android Applications Discussions' started by 25cents, Aug 3, 2010.

  1. Danariel

    Danariel Member

    Joined:
    Jun 30, 2010
    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Nashville, TN
    Ratings:
    +0
    Myth, I had this happen to me today, too with Navigator. I hadn't realized that I usually go through Maps, where I DON'T get the pop up message, and find the address, then hit directions and Navigate.

    However, if I go from my car dock application and use the Navigate button there, I don't get the popup.

    I use Custom Car Home, and have now replaced the Navigation application with the Blue Compass Arrow on there with the Navigation Shortcut that looks like a GPS unit that came with Car Dock V2 (then I uninstalled Car Dock V2. It still works somehow.)

    Hope this helps! Oh, and my Compass app doesn't work as intended, either, I still have to hit the button to turn GPS on there, too. Dammit...
     
  2. madslackin

    madslackin New Member

    Joined:
    Jan 20, 2010
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    This does work when the phone is locked and the screen is off, but it also works when the phone is unlocked and the screen is on (ie. every time you open the keyboard it'll open the messaging app). I don't want that. I want it to ONLY work when the phone is locked and the screen is off. Any ideas on how to make that work?
     
  3. mike789

    mike789 New Member

    Joined:
    Aug 6, 2010
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Add a context where the state of the screen is off.
     
  4. JoeKacz

    JoeKacz Member

    Joined:
    Mar 4, 2010
    Messages:
    74
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    Yep... this works for me.
     
  5. mazzthepianoman

    mazzthepianoman New Member

    Joined:
    Aug 29, 2010
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Newark, Ohio USA
    Ratings:
    +0
    Here are two context/tasks that turn on my wifi when I am in range of my home router and turn off my wifi when I leave the range of the wifi I am connected to (so it also works away from home like when I leave a Starbucks)

    Context 1
    Wifi Near
    SSID (put in the name of your router that shows up when you are connected)
    Toggle Wifi (checked)

    Task 1
    Wifi
    Set On

    Context 2
    Wifi Connected
    Invert (checked)

    Task 2
    Wifi
    Set Off

    I have the wifi check interval at 600 (10 minutes) which I hope will not be too much of a drain on the battery.

    I run wifi whenever I am home because it seems to use much less power than the 3G connection I can get.
     
  6. Droids

    Droids Member

    Joined:
    Nov 23, 2009
    Messages:
    793
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    I must be missing something here. Android does this by default. My droid is set up to use wi-fi at home and at work, everywhere else it uses 3g. It switches automatically when I'm in range of the networks. I suspect you might be doing this because you don't want the w-fi service running all the time? I let wi-fi, bluetooth, gps, (all services) run 24/7. If they're not needed by an app, they don't use any battery. Why all the effort to duplicate what Android does just fine on it's own?
     
  7. mazzthepianoman

    mazzthepianoman New Member

    Joined:
    Aug 29, 2010
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Newark, Ohio USA
    Ratings:
    +0
    And how does Android know when you are home to reconnect to the memorized router SSID? Wifi is powered and searching which is why I want to power it off when I am away from home. I have 10 IMAP folders running IDLE push so I need to conserve my battery when I can to make it through the day.

    I revised my method since it was toggling the wifi on every time I unlock the screen even though I was setting a 10 minute cooldown.

    The following profiles check every 15 minutes and connect me to my home router if it is in range. It will also disable wifi whenever I disconnect from my current connection whether it be at home or at a Starbucks.


    Profile Home Wifi
    Context
    Wifi Near
    SSID: myroutername
    toggle wifi checked
    Task(s)
    Wifi On

    Profile Wifi Connected
    Context
    Wifi Connected
    Task
    Profile Status "Wifi Disconnect" on

    Profile Wifi Disconnect
    Context
    Wifi Connected invert
    Task
    Wifi off
    Profile Status "Wifi Disconnect" off

    Profile Home Wifi Checker
    Context Time every 15 minutes
    Task Profile Status "Home Wifi" On
    Task Wait 30 seconds
    Task Profile Status "Home Wifi" Off
     
  8. NebulaOcton

    NebulaOcton Member

    Joined:
    Jun 24, 2010
    Messages:
    328
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    I loaded the Navy Bells profile from the tasker wiki, but I want it to mute Listen when the bells chime. I have Listen start when I plug in headphones and set a variable %LST to 1. I tried using the android media pause and pause toggle to trigger when the bells program triggers but only if %LST is set to 1. That did not work.

    Anyone have an idea on what I can do?
     
  9. NebulaOcton

    NebulaOcton Member

    Joined:
    Jun 24, 2010
    Messages:
    328
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    This would be awesome. But it would be better if you also create a profile that speaks the current conditions and the forecast for the next two days out loud.. I would do it my self if I had the xml experience but I'm a hardware guy not software.
     
  10. madslackin

    madslackin New Member

    Joined:
    Jan 20, 2010
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Thanks Mike, this worked!

    EDIT: Maybe I was a bit quick to declare it working. It does seem to work now, but it's not consistent.

    After a phone restart:
    Screen is off, keyboard is closed.
    I open the keyboard and the keyguard is off and messaging app is open. Perfect.

    Any subsequent attempt at this:
    Screen is off, keyboard is closed.
    I open the keyboard and the keyguard is ON. When I unlock it, the messaging app is open.

    It seems like Tasker still recognizes the keyboard is open and screen is off, and it does open the messaging app, however it doesn't disable the keyguard. Any idea on why that is?

    EDIT #2: Ran into another issue, also with the keyguard behavior not being consistent.

    I have a very simple profile set that says when the phone is plugged in, turn the keyguard off, with the exit task of turning the keyguard on. I have it plugged in right now and the keyguard stays on. The notification pane even says that 'keyguard off while plugged in' is the active profile, however if I leave the phone sit until the screen goes off and hit the lock button to turn on the screen, the keyguard is on. The frustrating part about this is I can try this over and over without making any changes to the phone, and some of the time the keyguard will be on, while other times it will be off.
     
    #118 madslackin, Aug 31, 2010
    Last edited: Aug 31, 2010
  11. zeroforum

    zeroforum New Member

    Joined:
    Sep 2, 2010
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Great thread - I've been lurking for a while and programmed a lot of these with great success.

    I do have one question - I set these scripts up: Lock your phone and locate it by SMS and sound - Tasker Wiki and added a Lock action at the end of the Task, so it would set the keypad pattern, then lock it.

    Is there a way to have it deactivate the keyboard pattern upon unlocking, but only for the unlock immediately after that profile runs? So basically if I lose my phone, I'll activate the script and it'll lock. When I recover it, upon unlocking the phone the keyboard pattern should deactivate.

    Also a separate but sort-of related question - since I ran the above script, I can't deactivate the keyboard puzzle through MENU > Settings > Security anymore. I can see the green check next to Require Pattern, but the box is grayed out and I can't click it. How do I deactivate it?

    Thanks for the help.
     
    #119 zeroforum, Sep 2, 2010
    Last edited: Sep 2, 2010
  12. NebulaOcton

    NebulaOcton Member

    Joined:
    Jun 24, 2010
    Messages:
    328
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    Zeroforum,
    At the end of your script set a variable %KEYGUARD to 1

    Start a new profile
    Context - Display - Screen unlocked
    Task - Display - keyguard off - if %KEYGUARD matches 1
    Task - Variable - Set Variable - %KEYGUARD to 0
     
Search tags for this page

android tasker examples

,
best tasker profiles
,
tasker android examples
,

tasker examples

,
tasker flashlight
,
tasker force close app
,
tasker profile examples
,
tasker random ringtone
,
tasker sleep timer
,
what have you done with tasker