Weird Issue On Droid X - Help Please

Discussion in 'Droid X Tech Support' started by Brian52682, Jul 12, 2011.

  1. Brian52682

    Brian52682 New Member

    Joined:
    Jul 12, 2011
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    So today I went into my Droid X and it said I had available updates, I selected update all and now there is a continual loop in my drop down menu of app's being downloaded and several of the app's are on there 3-4 times. I have rebooted the phone, turned airplane mode on, taken the battery out for 30 seconds, basically everything I can think of but every time it boots up I am still having these issues. Right now I am looking at my drop down menu at the top and it shows 5 apps downloading and the + has 40 next to it but there are 6 apps listed in what appears to be a loop. Does anyone have any idea how to resolve this?

    Thanks for any help anyone can provide!
     
  2. comk4ver

    comk4ver Member

    Joined:
    Jul 25, 2010
    Messages:
    627
    Likes Received:
    14
    Trophy Points:
    18
    Ratings:
    +14
    Maybe take off the automatic updates and do them in batches of three or individually.. also try going on a wifi connection for a while then connect back to 3g.

    Sent from my DROIDX using DroidForums
     
    #2 comk4ver, Jul 12, 2011
    Last edited: Jul 12, 2011
  3. Brian52682

    Brian52682 New Member

    Joined:
    Jul 12, 2011
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Thanks for the reply but the underlying issue is with the current downloads. My phone for some reason thinks these apps are downloading but they are not, some of them appear to be installing, some downloading (various percentages, some 4%, 15%, 95%, etc) and I can't cancel the downloads. This problem is very annoying as it is draining my battery but what do I do when Market doesn't recognize I am downloading anything. Does anyone have any suggestions on how to clear my drop down menu.

    Edit: I have done the 3G to WiFi for about 3 hours back to 3G and nothing.
     
  4. comk4ver

    comk4ver Member

    Joined:
    Jul 25, 2010
    Messages:
    627
    Likes Received:
    14
    Trophy Points:
    18
    Ratings:
    +14
    There's an option about disabling goggle's automatic backup then go into airplane mode.. Come back into 3g then go into the market and disable the automatic option on each app... Then click on the portion og the app that shows the percentage long pores on it... That should cancel the download.

    Sent from my DROIDX using DroidForums
     
  5. nlinecomputers

    Joined:
    Apr 13, 2010
    Messages:
    450
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Texas
    Ratings:
    +1
    Settings/Applications/Manage Applications/all

    Find Market and force close it. Then clear data. Find Market Updater and do the same. Reboot. See if you can get in to market and see your apps. You may have apps listed as not installed even if they are installed. Easiest fix is just to reinstall those apps.
     
  6. comk4ver

    comk4ver Member

    Joined:
    Jul 25, 2010
    Messages:
    627
    Likes Received:
    14
    Trophy Points:
    18
    Ratings:
    +14
    See the x on the top right hand corner... Press that
    Sent from my DROIDX using DroidForums
     
  7. ABQNM

    ABQNM Member

    Joined:
    Oct 12, 2010
    Messages:
    502
    Likes Received:
    1
    Trophy Points:
    18
    Ratings:
    +1
    I have had that happen before as well. You can't actually cancel them in the Market because they only appear to be downloading in the notification bar. When you go to the Market, they are not downloading, so no way to cancel. When it happened to me, I deleted data for Market and Market Updater, rebooted and all was well. To help prevent this, I do not do update all and when I update apps, I wait until the previous one goes from starting download to downloading before I start the next one. Otherwise that is when I get the issue of the market telling me it will be downloaded, but it doesn't do it.
     
  8. nlinecomputers

    Joined:
    Apr 13, 2010
    Messages:
    450
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Texas
    Ratings:
    +1
    I have this happen if I am using wifi and let the screen die. That disconnects me from Wifi and tends to blow up the download. If you keep the screen on it will work.
     
  9. Brian52682

    Brian52682 New Member

    Joined:
    Jul 12, 2011
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I have uninstalled all the apps listed but they are all still up there, it's like they don't actually exist but they are just clogging my drop down menu.

    Edit: Thanks guys for the help btw.
     
  10. nlinecomputers

    Joined:
    Apr 13, 2010
    Messages:
    450
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Texas
    Ratings:
    +1
    Have you forced closed and clear the data on the Market app itself? That is your problem. Market has hung up and needs it's data cleared out.
     
  11. Brian52682

    Brian52682 New Member

    Joined:
    Jul 12, 2011
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Yes I have on Market but Market Data is not running. I have rebooted 5 times and they are still just sitting there. I even just took my battery out for a minute then booted back up and they were still there.

    Edit: UGH.... have tried everything in this topic but they are still there... I am totally clueless right now.
     
    #11 Brian52682, Jul 12, 2011
    Last edited: Jul 12, 2011
  12. ABQNM

    ABQNM Member

    Joined:
    Oct 12, 2010
    Messages:
    502
    Likes Received:
    1
    Trophy Points:
    18
    Ratings:
    +1
    You can change this setting in the wifi settings. Go to settings>wireless and networks>wifi settings> press menu and choose advanced and then change the wifi sleep mode to never. Then if wifi is connected it won't switch back to 3g when the screen is off. The point of this is to keep the phone from searching for wifi access points when you are not connected. Just shut wifi off when you leave the area or use tasker to do it for you.