Upgrade from Android 6.0 to 7.0. Now clicks and pops with USB Audio

Discussion in 'Android Support' started by Svperstar, Oct 31, 2017.

  1. Svperstar

    Svperstar New Member

    Joined:
    Oct 31, 2017
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Current Phone Model:
    Moto X Pure
    So I am on a Moto X Pure. It came with 5.1.1 and I upgraded to 6.0 with zero issues.

    This Friday I did the OTA update to Android 7.0.

    Its working great besides 1 issue. I have a car stereo that supports USB Audio from Android. I use a USB cable and plug right into the stereo as it allows higher sound quality than Bluetooth.

    Now when I use my car stereo I hear clicks and pops in the music. I never heard this before on Android 6.0. If I switch to Bluetooth is goes right away so the problem is the USB Audio. I tried changing the buffer and thread priority on my music app(PowerAMP) which I have never had to mess with before and it made no difference.

    Did Android 7.0 change how USB Audio works? I see nothing even under developer options. Is there a way I can tweak the settings?

    Thanks
     
  2. me just sayin

    me just sayin Diamond Member

    Joined:
    Jun 7, 2017
    Messages:
    6,461
    Likes Received:
    4,557
    Trophy Points:
    1,778
    Location:
    35.7051° N, 89.9695° W
    Ratings:
    +4,695
    Current Phone Model:
    Note 8
    have you tried a different cable? I know it may not make sense since the problem started after an update but stranger things have happened.