Unlocked and rooted for battery life

Discussion in 'Samsung Galaxy Nexus' started by SwagTech, Apr 23, 2012.

  1. SwagTech

    SwagTech Member

    Joined:
    Feb 18, 2012
    Messages:
    190
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    I really only flashed a rom and kernel to achieve the same increased battery life as others claim to see. However, I noticed that my battery life is worse now than before I was rooted!!!
    I'm currently running the AOKP rom and Franco kernel. 4g off, only on wi-fi at home. I can literally see the percentage drop every few minutes.
    Can anyone suggest some settings I should use with the kernel?
    I also installed a new launcher, can they affect battery life?
    I absolutely love this phone though, so I'm willing to deal with the issues. I have a 3800mah extended battery but I hate the bulk.
    I like my nexus slim, naked with no screen protector. The feel of the screen and phone is a plus.

    Sent from my Galaxy Nexus using DroidForums
     
  2. syndicate0017

    syndicate0017 Silver Member

    Joined:
    Feb 2, 2011
    Messages:
    2,007
    Likes Received:
    48
    Trophy Points:
    113
    Ratings:
    +48
    Post a screen shot of your current usage. Let's see if you're hitting deep sleep or not.

    Sent from my Galaxy Nexus using Tapatalk 2
     
  3. SwagTech

    SwagTech Member

    Joined:
    Feb 18, 2012
    Messages:
    190
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    I haven't used it much as normal, but here are the results.

    Sent from my Galaxy Nexus using DroidForums
     

    Attached Files:

  4. SwagTech

    SwagTech Member

    Joined:
    Feb 18, 2012
    Messages:
    190
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    Forgot one shot..

    Sent from my Galaxy Nexus using DroidForums
     

    Attached Files:

  5. syndicate0017

    syndicate0017 Silver Member

    Joined:
    Feb 2, 2011
    Messages:
    2,007
    Likes Received:
    48
    Trophy Points:
    113
    Ratings:
    +48
    Holy crap...it looks like you have a MASSIVE wake lock issue. If you look at your first screen shot, it appears your phone never enters deep sleep. Click on your battery stats (menu-settings-battery and click graph). Is the awake line a giant blue line? That's how it appears. Download better battery stats or bad ass battery and we'll try and isolate the wake lock.

    Edit: just saw your other shot. Still looks like some nasty wake locks. But not as bad as it first appeared. Your phone is entering deep sleep at some points but you have some nice long awake points. Though that could be due to phone calls.

    Sent from my Galaxy Nexus using Tapatalk 2
     
  6. sbenson

    sbenson Silver Member

    Joined:
    Jan 19, 2011
    Messages:
    2,370
    Likes Received:
    61
    Trophy Points:
    113
    Location:
    Virginia/DC Metro Area
    Ratings:
    +61
    Yeah, try better battery stats to narrow down the issue. Most likely a rouge app.
     
  7. SwagTech

    SwagTech Member

    Joined:
    Feb 18, 2012
    Messages:
    190
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    So it appears as though I'm just a heavy user? What other screen shots can I show? Or do you mean wait til the phone needs charging?

    Sent from my Galaxy Nexus using DroidForums
     
  8. sbenson

    sbenson Silver Member

    Joined:
    Jan 19, 2011
    Messages:
    2,370
    Likes Received:
    61
    Trophy Points:
    113
    Location:
    Virginia/DC Metro Area
    Ratings:
    +61
  9. SwagTech

    SwagTech Member

    Joined:
    Feb 18, 2012
    Messages:
    190
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    Sent from my Galaxy Nexus using DroidForums
     

    Attached Files:

  10. syndicate0017

    syndicate0017 Silver Member

    Joined:
    Feb 2, 2011
    Messages:
    2,007
    Likes Received:
    48
    Trophy Points:
    113
    Ratings:
    +48
    Your kernel seems to be a source of the unusually high amount of drain. On the Franco kernel, have you enabled hotplugging, undervolted, or overclocked? Your phone may not be handling it well and is actually suffering from one of the changes you may have made. Also, I'd let it cycle once or twice before we started making many changes. It's best to judge a kernel and battery only after at least 48 hours.
     
  11. SwagTech

    SwagTech Member

    Joined:
    Feb 18, 2012
    Messages:
    190
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    I tried these settings after someone suggested it in the forum. However, I haven't altered the voltage settings.

    Sent from my Galaxy Nexus using DroidForums
     

    Attached Files:

  12. sbenson

    sbenson Silver Member

    Joined:
    Jan 19, 2011
    Messages:
    2,370
    Likes Received:
    61
    Trophy Points:
    113
    Location:
    Virginia/DC Metro Area
    Ratings:
    +61

    Your minimum cpu voltage is way too high. Set it to 384 and leave it. Enable generic hotplug and set your governor to hotplug as well. Leave under volting alone.

    Which kernel are you running? Milestone 2 or one of the nighties? Also when you downloaded the kernel, which gpu version did you select? 384 or 512? 512 doesn't play well with some phones.

    Sent from my Galaxy Nexus using Tapatalk
     
Search tags for this page

best franco kernel settings

,

root galaxy nexus battery life