Screen Timeout - Undocked vs. Docked

Discussion in 'Android General Discussions' started by cyberhap, Nov 20, 2009.

  1. cyberhap

    cyberhap New Member

    Joined:
    Nov 10, 2009
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I like to keep my screen timeout set at 2 minutes, because if I leave it set to "Never Timeout" I'll just plain forget to turn the screen off. With battery life a precious commodity, I can't afford to forget.

    When I dock it in the Multimedia Station, however, I want the Droid to stay on at all times (for the clock, weather, etc). It's why I bought the dock. With it set to 2 minute timeout, the dock closes the screen after 2 minutes. Not nice!

    That said, I can't find any way to 'have it both ways'. I either keep it set to a 2 minute timeout and the dock will turn off, or set it to never timeout and fear battery drain.

    Any suggestions? I don't see any separate dock or charging settings, which stinks. How are you configuring this?

    Thanks
     
  2. GolfProRM

    GolfProRM Member

    Joined:
    Nov 11, 2009
    Messages:
    262
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Lincoln, NE
    Ratings:
    +0
    If you have Locale, you can setup a profile so if the phone is charging, the screen won't timeout. That's how I have mine setup - also works great in the car this way.
     
  3. wil318466

    wil318466 Member

    Joined:
    Nov 12, 2009
    Messages:
    684
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    Agreed.

    I had the same issue with the screen timing out while driving and listening to radio and whatever. Download Locale, set up 2 profiles, one for "plugged" one for "unplugged". Its under "battery" settings, then "display settings" as a setting. ("Battery" is the condition").

    -Wil
     
  4. LifeIsABeach

    LifeIsABeach Active Member

    Joined:
    Nov 2, 2009
    Messages:
    1,283
    Likes Received:
    0
    Trophy Points:
    36
    Ratings:
    +0
    I have mine set to 30 seconds and that works great for me. However, when I have it in the docking station it always stays on the whole time (no Locale, Screebl, or any other app set). I assume it is because I keep it plugged in when it is in the dock (this way you get an alarm clock and a freshly charged phone every night).
     
  5. mrschmitz

    mrschmitz Member

    Joined:
    Nov 8, 2009
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Iowa, U.S.
    Ratings:
    +0
    No app needed! From the main settings:

    Applications->Development->Stay awake.

    "The screen will never sleep while charging." That is exactly the behavior I wanted, and now have.
     
  6. cyberhap

    cyberhap New Member

    Joined:
    Nov 10, 2009
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    All excellent suggestions! Thanks! :)

    I wonder why they hid the setting in "Development"? I think that was the only menu on the phone I didn't click through.
     
Search tags for this page

how to get galaxy s3 screen to stay on when docked

,
how to undock a galaxy s4
,
how to undock a galaxy s4 active
,
keep htc incredible on when docked
,
s4 screen timeout while docked
,
screen off while docked galaxy s4
,
screen timeout entries never timeout
,
set xoom to never sleep when docked
,
undock galaxy s4
,
why does my display always sleep while docked