Phone forgetting default "Home" App

Discussion in 'Android General Discussions' started by tameone, Apr 12, 2010.

  1. tameone
    Offline

    tameone New Member

    Joined:
    Apr 12, 2010
    Messages:
    262
    Likes Received:
    0
    Trophy Points:
    0
    My Droid forgets that I have selected HelixLauncher as my default Home app EVERY TIME I long press the Home button to bring up the app switcher.

    It doesn't matter if I select an app from the switcher or not.. the association is lost and I have to reselect HelixLauncher as default on next press of Home. If I do not bring up the task switcher, the association will be remembered.

    It's very annoying to have to select Helix every time after I want to multi-task by using the app switcher. Any ideas what could be wrong?

    edit: does the same thing on HelixLauncher2 beta And Home++ so it's definitely a function of the phone, not the app.. maybe I should post somewhere else :D
    Last edited: Apr 12, 2010
  2. jsh1120
    Offline

    jsh1120 New Member

    Joined:
    Dec 9, 2009
    Messages:
    2,462
    Likes Received:
    1
    Trophy Points:
    0
    Location:
    Seattle, Washington
    You might try downloading an app called "Home Switcher." Even if you don't use long-term, it may help you diagnose your problem. In effect, it places a widget on your screen that allows you to select any launcher you have on your phone and designate it as the default until you want to switch to another.
  3. tameone
    Offline

    tameone New Member

    Joined:
    Apr 12, 2010
    Messages:
    262
    Likes Received:
    0
    Trophy Points:
    0
    Thanks for the suggestion, but when I heard about that app I tried it out as a possible fix and it didn't help. I selected HelixLauncher as my default through Home Switcher, but after a long press on Home key to bring up the app switcher, the default association was lost when I pressed Home again!

    Edit: I see you suggested I use it simply to diagnose. The phone is definitely losing the association. That is, Home Switcher tells me my default is not determined yet after I go through the spiel with the app switcher, even if I has just previously set the default USING Home Switcher.

    On a side note, the home app (whatever I have running as default currently) SHOWS UP in the app switcher. I don't think this should happen. I.e. if I'm running HelixLauncher and bring up the app switcher, I see HelixLauncher as a running app. I would assume this should be invisible.
    Last edited: Apr 12, 2010
  4. tameone
    Offline

    tameone New Member

    Joined:
    Apr 12, 2010
    Messages:
    262
    Likes Received:
    0
    Trophy Points:
    0
    Here is a simple rundown to make understanding the problem very simple :)

    1) Install a home screen replacement, say HelixLauncher.

    2) Press "Home" key, brings up Complete Action using box

    3) Check "use by default for this action", select HelixLauncher

    4) Single pressing home now, while doing anything on the phone and in any app, will return me to home without a problem.

    5) Long press "Home" to bring up app switcher (I see HelixLauncher listed)

    6) Single pressing home now will result in the phone asking what I wish to use to complete this action.. that is, it has totally forgotten that I just make HelixLauncher the default.

    The only thing that makes the phone forget is long pressing "Home" to bring up the app switcher. Doesn't matter if I select an app from the app switcher, if I press "back" button to return to what I was doing, or if I single press "Home".. the association is lost immediately after the long press of "Home"

    This didn't always happen, but I cannot pin point any changes I made on the phone that might be causing it. IIRC, it was happening before the 2.1 update.
    Last edited: Apr 12, 2010
  5. Mojoman
    Offline

    Mojoman New Member

    Joined:
    Dec 1, 2009
    Messages:
    41
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    MA
    When I long press on home, HelixLauncher is not listed on the app switcher. I only see the last apps used. I'm running stock 2.1 and Helix 1.
  6. tameone
    Offline

    tameone New Member

    Joined:
    Apr 12, 2010
    Messages:
    262
    Likes Received:
    0
    Trophy Points:
    0
    I think the problem is something is killing the Home app and causing turmoil. I've been told the Home app should be running ALL the time, even when not being used as default "Home". I have no task killers. I've force closed all applications I can on the phone, but Home is still being killed by something. Any thoughts?
  7. Mule65
    Offline

    Mule65 Member

    Joined:
    Apr 7, 2010
    Messages:
    430
    Likes Received:
    0
    Trophy Points:
    16
    Uninstall HelixLauncher and things will work better.
  8. tameone
    Offline

    tameone New Member

    Joined:
    Apr 12, 2010
    Messages:
    262
    Likes Received:
    0
    Trophy Points:
    0
    Well obviously, but it's clearly a problem with my phone, not Helix, and I'd like to resolve it.

    This didn't used to happen, and now it happens with every home replacement app I've tried. I'm heading towards doing a complete wipe because I can't pin point anything that changed.
  9. jsh1120
    Offline

    jsh1120 New Member

    Joined:
    Dec 9, 2009
    Messages:
    2,462
    Likes Received:
    1
    Trophy Points:
    0
    Location:
    Seattle, Washington
    If you have not already done so do the following:

    Settings>Applications>Manage Applications>Menu>Filter>All Apps. Select the "Home" app and clear the data and the cache. If you can, clear defaults. Now do the same thing for the Helix Launcher.

    Then go to Home Switcher and select Helix as your default. Return to the Helix launcher via the commands above and check to see that its "clear defaults" button is active. (Don't press it.) And do the same for "Home." You shouldn't be able to "clear defaults" because it isn't a default.

    If these operations lead to unexpected results, I think your next step is a factory reset. (Assuming, of course, that you've tried pulling your battery at least once during this entire orderal.)

    P.S. You have tried uninstalling and reinstalling Helix Launcher, right?
    Last edited: Apr 13, 2010
  10. tameone
    Offline

    tameone New Member

    Joined:
    Apr 12, 2010
    Messages:
    262
    Likes Received:
    0
    Trophy Points:
    0
    I've tried battery pulls and all the like before with no luck.

    I just tried clearing Data for Home, and following your procedure (and several variations) but the problem persists.
  11. jsh1120
    Offline

    jsh1120 New Member

    Joined:
    Dec 9, 2009
    Messages:
    2,462
    Likes Received:
    1
    Trophy Points:
    0
    Location:
    Seattle, Washington
    Sorry to hear that. Assuming you're tried uninstalling/reinstalling Helix and tried the process with at least one other Home replacement, I think you're next step is a factory reset. If you figure it out, I'd be interested in hearing what the problem turns out to be.
  12. tameone
    Offline

    tameone New Member

    Joined:
    Apr 12, 2010
    Messages:
    262
    Likes Received:
    0
    Trophy Points:
    0
    Yea, I've uninstalled probably 10 times and tried several other apps (Home++, Helix 2 beta, Panda Home).. all with identical results. Thanks for your help.
  13. tameone
    Offline

    tameone New Member

    Joined:
    Apr 12, 2010
    Messages:
    262
    Likes Received:
    0
    Trophy Points:
    0
    Welp, I did a factory reset and cleared the cache partition last night and the problem is obviously gone.. so I guess we will never know the real reason.

    I didn't reinstall a lot of the apps I never used, and overall the phone is noticeably snappier. The only issue I'm seeing, and this might be placebo effect, is download speeds seem slow, but I'll wait before making any conclusions.
    Last edited: Apr 14, 2010
  14. jsh1120
    Offline

    jsh1120 New Member

    Joined:
    Dec 9, 2009
    Messages:
    2,462
    Likes Received:
    1
    Trophy Points:
    0
    Location:
    Seattle, Washington
    Happy to hear your problem is solved. My guess is that clearing your cache was the key simply because with so many users with so many different apps I suspect your problem would have been duplicated by someone somewhere.

    Cache problems are common and not easy to diagnose. Bad "housecleaning" practices on the part of individual apps combined with coding that grabs cached code when it's available can be a real headache.

    As for slow downloads, I think that's a red herring. I've been downloading/updating a number of apps over the last few days and have noticed very slow performance in a number of cases. I've just assumed it stems from ever heavier demand on the Market servers and a lot of apps being updated after the 2.1 update.
  15. sheriffwoody
    Offline

    sheriffwoody New Member

    Joined:
    Feb 17, 2010
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    0
    My Helix Launcher does the same thing and I am looking for a solution. Helixlauncher keeps asking (after pressing the home button) "complete action using" and I have to hit 'always use' then helixlauncher. but 10 seconds later if i hit the home button again i have to do it all over again. gets annoying (this whole droid thing is anoying, i gave up my iphone for the droid way back in november, and the droid is waaaay to clitchy)...
    My helix acts this way even without a long press.
    And yes my droid is slow as he*k.
    I actually had to install helixlauncher because my droid homepage kept hiding the homepage icons until i pulled the battery. now helixlauncher is anoying too. pulling the batter hasnt helped.
    is there a way to clear the cache without a factory reset?
    AAAAARRRGGGGG
  16. jkennebeck
    Offline

    jkennebeck New Member

    Joined:
    Aug 20, 2010
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    I think just wiping the dalvik cache works.
    I had this issue between the HTCSense-like BAMF rooted ROM I use and Launcher Pro Plus.
    Wiped dalvik using clockwork recovery and the issue has disappeared.
    Good luck!
Search tags for this page

andriod where is home key association kept

,
android default launcher forget
,

android device keeps asking for default home app

,

android forgets default home

,

android forgets default launcher

,
android keeps asking for default launcher
,
change default home screen when home key is pressed android
,
clear defaults android keeps asking
,
device keeps asking me for home launcher
,
galaxy s3 forgets default app
,
galaxy s4 losing launcher default
,

s4 asks to set home to default every time