On my second Droid and.......

Discussion in 'Android Tech Support' started by jjb2, Dec 3, 2009.

  1. jjb2

    jjb2 Member

    Joined:
    Nov 6, 2009
    Messages:
    61
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Hollywood, FL
    Ratings:
    +0
    My first Droid people complained that they could not hear me. I returned it and now people say they can hear me fine, BUT they also hear themselves echo. I have no case on the phone and the earpiece volume is all the way down. Any suggestions or do I need to exchange this Droid too? Thanks.
     
  2. RobC3421

    RobC3421 New Member

    Joined:
    Nov 20, 2009
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
  3. cereal killer

    cereal killer DF Administrator Staff Member

    Joined:
    Oct 29, 2009
    Messages:
    11,268
    Likes Received:
    1,059
    Trophy Points:
    558
    Location:
    Austin, TX
    Ratings:
    +1,125
    Current Phone Model:
    Nokia Lumia Icon
    turn off voice privacy, dial #228 choose option 1 and then 2, restart the phone.

    voice privacy can be found in settings/call settings/voice privacy
     
  4. liltenou

    liltenou New Member

    Joined:
    Nov 17, 2009
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    New York
    Ratings:
    +0
    My first droid would reboot in the while I was listening to music. I use MixZing as a music player.
    I went back to facotry default and only used the built in player. Same issue.
    So yeah, I'm on my second droid too...... :dry: