Not Tech saavy, need help with wifi connection

Discussion in 'Android Tech Support' started by kgoller87, Jul 5, 2012.

  1. kgoller87

    kgoller87 New Member

    Jul 5, 2012
    Likes Received:
    Trophy Points:
    I will start out by saying I am not tech saavy. I have a cisco valet router that pretty much is idiot proof to set-up and gives me a network name and password to enter into new devices to connect them.

    All devices in my house are connected and working except my droid charge. It has worked the past couple days but now will not connect to my home wifi. Although my husband has an android phone and it is connecting just fine.

    The networks show up (I have a private network and a guest network) but when I try to connect to either one it just keeps saying "obtaining IP address" and then it disconnects and starts all over again saying "obtaining IP address".

    I have talked to my cisco router support and samsung support and neither were able to help me. I have done the following things already...

    1. Rebooted my phone.
    2. Rebooted my router.
    3. "Forgot" the network and rebooted my phone by taking the battery out and tried to connect again.
    4. "Forgot" the network, rebooted phone by taking the batter out and rebooted the router and manually tried to connect by putting in my SSID and password

    Please do not reply by saying how I do not know anything and please try to explain things rather "slowly" for me.
Search tags for this page

cisco connection wifi password bionic babe


droid bionic cisco guest connect


how to connect my droid incredible phone to a cisco valet ro