Error applying 246 to Rooted 905

Discussion in 'Motorola Droid Bionic' started by jtapczynski, Sep 28, 2012.

  1. jtapczynski
    Offline

    jtapczynski New Member

    Joined:
    Mar 1, 2012
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Hi,

    I have a rooted 905 system and I was trying to apply the 246 leak and I'm getting the following error.

    -- Install /sdcard...
    Finding update package...
    Opening update package...
    Verifying update package...
    Installing Update...
    Verifying current system...
    assert failed: apply_patch_check("/system/bin/mount_ext3.sh". "1810bb2cd607e2fbeafa158bb3a89629d60b7" . "3a8382950bd4a6226349607d099afcbd93653d48")
    E:Error in /tmp/sideload/package.zip
    (Status 7)
    Installation aborted.

    Because I'm rooted, do I have to use the HoB to upgrade to ICS?

    Thanks
  2. syndicate0017
    Offline

    syndicate0017 Silver Member

    Joined:
    Feb 2, 2011
    Messages:
    2,010
    Likes Received:
    48
    Trophy Points:
    113
    Ratings:
    +48
    I'm far from an expert on the Bionic, but that looks like an MD5 error.
  3. TMYINC
    Offline

    TMYINC Member

    Joined:
    Sep 30, 2010
    Messages:
    377
    Likes Received:
    4
    Trophy Points:
    18
    Ratings:
    +4
    If you are not on a stock ROM the update won't apply due to a security check. That's what it looks like to me. The quick and easy way would be to install Sam's HoB and install 246exe and select it when you run HoB. Just follow his instructions in the thread and refer to his FAQ if you have any questions. Longer and harder way would be to grab rsd lite and the 905 fxz file. Run the fxz through rsd lite, apply update in stock recovery, then root with razors edge or HoB. Hope this helps.

    Sent from my XT875 using Tapatalk 2