Droid X Help!

Discussion in 'Android Support' started by Kjguy43, Feb 6, 2011.

  1. Kjguy43

    Kjguy43 New Member

    Joined:
    Aug 13, 2010
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Ok here goes, may be a bit long. Have a Droid X that I put liberty 1.5v on. Worked great, changed some themes around and all. Decided to change out the screen protector to one a friend gave me. Ran it under water and then put windex on it to apply it. Used a rubber squezie to remove bubbles and such. I think some windex got down into buttons. So the phone freezes, turn it off, now all it does is shows liberty boot screen.

    I tried recover mode, nope it wont do it.

    Flashed it using RSD 4.6, went through the process, battery died. Read to use 4.9, got 4.9 and a fully charged battery, flashed usinf 4.9 and 2.340 software. Finished this time. Still wont boot past the word liberty.

    I am thinking the windex did something to it, the lights on the button do light up. But why if it fact is was the windex, why would it turn on but not boot.

    Cant send it back to verizon when it has a custom rom that I cant get rid of becuz i cant get it to boot

    Any ideas, suggestions?

    Thanks
     
  2. AWB

    AWB Member

    Joined:
    Dec 23, 2009
    Messages:
    61
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Mount Vernon, WA
    Ratings:
    +0
    Well Windex is defiantly not a friend to technology. That being said, sure you can send your phone back to verizon lol. Those people at the counter aren't gona have a clue what caused this boot loop. And if your discreet it should file nicely under extended warranty. Ive replaced my D1 3 times and all 3 times had a custom rom.
     
  3. Kjguy43

    Kjguy43 New Member

    Joined:
    Aug 13, 2010
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0

    Well I was able to flash it back to full 2.3.32 and then flashed system 2.3.34 on it, but it still wont go past the M logo. Which makes me believe the flash was a success because of stock logo. What baffels my mind, if in fact it was the windex, why would it turn on and let me flash and stuff but not boot? cant even get into recovery by holding power and home