Droid won't completely connect to my Wi-Fi

Discussion in 'Motorola Droid 2' started by Ace_437, Feb 7, 2011.

  1. Ace_437
    Offline

    Ace_437 New Member

    Joined:
    Feb 7, 2011
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    0
    Finally got my router back online and it's working fine. Try connecting to it with the Droid, and I get stuck at "obtaining IP address.....". If I disconnect and try a different open network it works just fine. I've got my router setup with WPA security, but typed in the correct key. I get past that point but am stuck at the damn IP step. Any ideas?
  2. mr_silent
    Offline

    mr_silent New Member

    Joined:
    Nov 26, 2010
    Messages:
    138
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Anchorage, Alaska
    What kind of router is it?

    Sent from my Droid using DroidForums App
  3. Dave12308
    Offline

    Dave12308 New Member

    Joined:
    Nov 15, 2009
    Messages:
    3,269
    Likes Received:
    50
    Trophy Points:
    0
    Go into the advanced settings for your wifi (on your Droid) and set a static IP address. I have the same problem with my Droid, I use a Linksys WRT54G router. My Coby Kryos tablet that runs Android 2.1 also has this issue. Not sure which router you have, but I can say for a fact that the WRT54G v2.1 does not play nice with 2.1 or 2.2 in DHCP mode. Back when the Droid was running Android 2.0; I don't remember having to use static IP.
  4. Ace_437
    Offline

    Ace_437 New Member

    Joined:
    Feb 7, 2011
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    0
    I've got the same router. :) I'll try that.
  5. Ace_437
    Offline

    Ace_437 New Member

    Joined:
    Feb 7, 2011
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    0
    So I don't see the option to enter an IP address for the phone. Where are the advanced settings?
  6. mr_silent
    Offline

    mr_silent New Member

    Joined:
    Nov 26, 2010
    Messages:
    138
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Anchorage, Alaska
    When your looking at the list of wifi networks, press menu and select advanced settings. I'm not sure, but I think your isp needs to support static ip, although It won't hurt to try.

    Sent from my Droid using DroidForums App
  7. Ace_437
    Offline

    Ace_437 New Member

    Joined:
    Feb 7, 2011
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    0
    Still can't get it to work. What a PITA. It connected once, but the internet wouldn't go anywhere. I added in a subnet mask and default gateway, but it didn't help. Any other ideas?
  8. Ace_437
    Offline

    Ace_437 New Member

    Joined:
    Feb 7, 2011
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    0
    Fixed it. I upgraded the firmware of my router and now it work like a charm. So much faster than using the Verizon network for data!

    It must have to do with the older WRT54G's.
Search tags for this page
android tablet linksys router
,

android tablet won't connect to wifi

,

android won't obtain ip address

,

android wont connect to wifi obtaining ip address

,
cant cinnect galaxy s3 to linksys
,
hipstreet tablet wont connect to wifi
,
my tablet wont connect to my wifi
,
phone wont obtain ip address
,
tablet won't obtain ip address
,
why does mi wifi dont read the ip adress
,
why does my coby tablet keep saying obtaining ip address
,

why won't my tablet connect to the internet