Apps take longer to open (about 1/2 a second) on 4G but open instantaneously on WIFI!

Discussion in 'Samsung Galaxy S3' started by rdroidj, Mar 28, 2013.

  1. rdroidj

    rdroidj New Member

    Joined:
    Nov 15, 2010
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I have the verizon version.

    This is happening to most of the apps like Clock, Chrome Browser, Facebook, Email, Yelp etc


    When I click on their icons to open them, nothing happens for 1/2 a second (it makes me think may be I didnt press correctly) and then the app opens.

    I noticed that this is not happening on the Sprint version of the phone that my co-worker has.

    Is this because of the Wifi Offloading that Verizon tries to do? Do others have a similar issue? How do you fix it?
     
  2. randizzard

    randizzard Member

    Joined:
    Jan 17, 2011
    Messages:
    138
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    This is typical on Verizon with the bloat ware killing the processor. Root and run a non bloat rom :)
     
  3. Sgt Fury

    Sgt Fury Member

    Joined:
    Dec 27, 2010
    Messages:
    155
    Likes Received:
    4
    Trophy Points:
    18
    Ratings:
    +4
  4. Sgt Fury

    Sgt Fury Member

    Joined:
    Dec 27, 2010
    Messages:
    155
    Likes Received:
    4
    Trophy Points:
    18
    Ratings:
    +4
    I would also switch to Firefox for web browsing. A much faster and kills adds on web sites if you use the plug-ins.
     
  5. rudywilliams

    rudywilliams Member

    Joined:
    Jun 11, 2011
    Messages:
    67
    Likes Received:
    6
    Trophy Points:
    8
    Location:
    Brentwood, CA 94513
    Ratings:
    +9
    Current Phone Model:
    Moto G 4 Plus
    I think you will find that delay may be just getting 4G going as it drops off when there is no activity.