AOSP roms USB issues

Discussion in 'Droid X Tech Support' started by devortex, Jan 8, 2011.

  1. devortex
    Offline

    devortex Developer Developer

    Joined:
    Aug 13, 2010
    Messages:
    352
    Likes Received:
    0
    Trophy Points:
    0
    Hello smart people.

    I have a quick question that has been stumping me for quite some time.

    When I use Apex rom or Fission, and connect my X to my computer, all usb settings work (media sync, pc mode, storage, and charge). Also via adb I can do adb remount and/or adb root. When I run adb shell, I immediately get the # prompt meaning I'm running with root access.

    Whenever I try using a more aosp rom, like Jrummy, Rubix or others, PC mode and Media sync end up breaking on MTP Device driver install so media sync is useless. Also adb remount fails and adb root gives an error that root is not allowed on a production build.

    I've checked build.prop to see if I can see anything out of the ordinary on these roms, but besides memory tweaks and things they are very close to the apex build.prop file.

    Is there somewhere else I should look where the rom determines if it's a production build? Are these two issues related? Does anyone else observe this? I know there was a thread in the rubix section where doing some kind of recovery reboot fixes the mtp device error, but that never worked for me, and there were mixed reports.

    Thanks.
Search tags for this page
aosp driver
,
aosp mtp
,
aosp mtp driver
,
aosp mtp drivers
,
aosp on maguro usb driver error
,
aosp rom usb
,

aosp usb driver

,
aosp usb file sharing
,
asop rom usb to pc
,
asop usb driver
,
mtp with aosp rom is buggy