Would anybody be willing to test out an ICS alpha for the Pro?


Jan 18, 2011
Reaction score
I got a Galaxy Nexus on release day so I have no service on my old Pro, but from playing around with it...
It's actually very smooth

The latest .zip (2/10/2012) fixes 3G data connectivity but I cannot say that GSM connectivity even works, let alone GSM data
Here's the .zip as promised I just wiped my system, data, and cache and installed the zip, then flashed gapps and rebooted

a few things to note:

You should wipe system, data, and cache
The initial boot time is pretty long; like 5 mins or so but my CDMA data connected right away and i was able to go through the initial startup of signing into google and whatnot.
You should not turn off USB debugging
If it wants you to activate your phone and you have to press 1, alt + 1 works fine
After you log into google, you should just let your phone sit for a minute or two while your phone syncs everything again

The camera still does not work! there is no ETA whatsoever

If you do not have a separate battery it is not recommended that you flash this as we currently have no way to power up the phone if a battery dies so it is imperative that you do not let your battery fully drain on this rom!!

In order to reboot into recovery do not flash the Droid 2 Bootstrapper! Long press the power button and select reboot, then recovery

md5sum: 6232b21238b7bb95694f66d0d5ae70d9

Live Wallpaper workaround: If you wish to have a live wallpaper, you may see that right after selecting it, it will turn on for a second, then revert back to a stock wallpaper. If you wish to keep a live wallpaper, right after pressing the "Set Wallpaper" button on the bottom, if you turn off the screen of your phone by pressing the power button and leave it alone for like 10 seconds, it *should* remain when you turn the screen back on. It may take a few tries.. just be sure to turn off the screen like a tenth of a second after choosing the "Set Wallpaper" button
flash the latest gapps from here -> http://goo-inside.me/gapps/
I'll test it out tomorrow. Phone is almost dead now. Was hoping you'd pick this up!
Haha I've been busy with the Kindle Fire! Gonna spend a lot more time on the Pro now. I love making alpha builds into actual releases. Just got the USB to mount as well as USB debugging to work at any time you plug the cord in. And we don't even have to plug in, then unplug, then replug it in to get it to work anymore like CM7! Hooray progress
I just try it but i installed wrong google market app.. i could not login on start up screen... but before i installed google app i had R above antenna bars.. camera did not work and keyboard backlight did not work..

installation proces: running cm7
Power button - reboot in to recovery
Bucked up room
Then whiped system / factory setting
Advance/ wiped dalvik/ wiped battery/wiped system cach/
Install from zip.
Install 2Alpha
Reboot .
Sent from my DROID Pro using DroidForums
Thanks to keep droid pro runnin.....

Sent from my DROID Pro using DroidForums
strange that you don't have a keyboard backlight. try checking off automatic backlight under settings -> display -> brightness
Just installed this and got it up and running:

1) Seems to be smooth and responsive so far. Haven't had any force closes yet.
2) Wifi is working just fine.
3) Calling is working

1) Data isn't working yet (FWIW, data didn't work on the other ICS alpha, either)
2) Call volume seems really low (more later)
3) Live wallpapers crashed when I attempted to use one. Doesn't impact me - never liked them.
4) As you mentioned, the portrait soft keyboard always displays when in a typing field. No big deal. I can live with that.

Regarding the call volume, that happened to me on the other ICS alpha also. Is there a call volume setting somewhere (besides the volume rocker in call)?

Very impressed. To be honest, the only thing preventing me from using at as a daily is the fact that data doesn't work at the moment. Since I'm at home today, I'm going to keep using it with wifi to see if I encounter any problems. Great job so far!
Well this is gonna suck. Trying to get data working without a data enabled phone = no fun

Sent from my Galaxy Nexus using DroidForums
Ah, didn't know your phone wasn't data enabled.

Guess it makes sense since you said you got a new one.
Also, I tried to install an app to boost the in-call volume and found out that there is not root access. How would I go about obtaining it?
i find it very strange that you don't have root access. my build does, perhaps it could be the app that's at fault? can you open the app called the terminal emulator and type "su" and see what it says after you press enter?
i find it very strange that you don't have root access. my build does, perhaps it could be the app that's at fault? can you open the app called the terminal emulator and type "su" and see what it says after you press enter?

I also downloaded Root Checker and it told me the same thing.

I restored back to CM7 for now, as I'm expecting some phone calls and needed sufficient volume to be able to handle that stuff.
Was able to take care of those important phone calls, so I restored the ICS backup. This time, root permissions weren't a problem. Not sure what happened originally. I cleared the SU data and tried again.

I was able to use Volume+ to increase the call volume (modifies your build.prop file) and now the only thing preventing me from keeping this ROM permanently is the data missing. Is there anything I can do to help you with that? I don't know anything about developing, but I'm willing to learn.
I'm actually making a build now. I added a few things that *may* result in data connectivity. What does that app add to your build.prop?

Sent from my Galaxy Nexus using DroidForums
I stopped the build process to switch to frameworks by Hashcode that hide the the keyboard while held vertical but show while horizontal. For some reason or another, if you want to watch a youtube video, it plays like crap unless you switch the mode to HD which is kinda the opposite of what to expect...

data might work too *fingers crossed*