WIFI won't connect

I was having intermittent issues at home with it as well... Until I used WiFi analyzer and found that there are 13 wireless networks on channel 5 (What I was using), 8 on 6, and 15 on 4... But only 3 on channel 1 and they're all weak :)
Gotta love living in an apartment complex!
Once i changed the router to channel 1, I haven't had an issue since.

I would've never thought to check for that... I'd tried everything else possible, no luck, I change the channel and BAM! Worked like a charm.

You have my thanks dancedroid
Can't get wifi to see my network

Shows up other nearby weak networks but not my strong 4 bar network.
My old Samsung Omnia in the same place recognizes it. SSID is broadcast and both other phone and my laptop see it just fine.
Any advice?
I have a question. I was under the impression that the new 2.2 update on the Droid 1 will allow it to be a hotspot.

Am I mistaken

If not how would I go about doing this?
I have a question. I was under the impression that the new 2.2 update on the Droid 1 will allow it to be a hotspot.

Am I mistaken

If not how would I go about doing this?

Unfortunately, even though that is part of Froyo, it is something that Verizon had stripped out from the software. Actually, I don't think the D1 can be a hotspot, though you can wirelessly tether if you're rooted.
I have had this problem sometimes before and what works for me is to forget the network and try reconnecting by entering the password in again. And if that doesn't work go into airplane mode and then come out of it and then try reconnecting

Sent from my Droid

this worked for me
Hopefully this thread isnt dead. Ive been having an issue getting my D2 to connect to my wifi. I have never had an issue connecting before, but after I recently did a factory reset, I cannot connect at all.
I created a thread talking about it on the droidforums:

Basically, when I turn wifi on, select my wifi network, enter my WEP key and hit connect, it says obtaining IP address then says disconnected, scans again and repeats the process. After sometime the wifi shuts off (probably a wifi setting). I have gone into the attached devices on the router and it shows my phone is connected, but I do not have a wifi connection on my phone, or atleast the wifi icon is not there and it uses 3G.
I have not tried changing the channel as some have stated but I will give that a shot. Current my router is set to auto and on channel 6. I did download wifi analyzer and it looks like theres a couple other routers operating on channel 6.
Hopefully itll work!
I got it figured out!!!!!!!!!!!!!!!

Here's the deal. When trying to add or configure a wireless network, the Droid asks for the network password. THIS ISN'T WHAT YOU NEED! What you are supposed to enter is your NETWORK SECURITY KEY.

Works like a champ now!

thanks ice that was the problem:)dancedroid
I had the right WPA/WEP authentication passcode in, but I fixed my wifi issues by the following:

Long press -> modify network config
I then took off 'DCHP' and selected 'manual'. From there I manually set a local IP address from my wifi access point (AP) I know is spare:
I then added the router IP (on the same range i.e. ending 192.168.0.x). Previously it had set itself on a totally different range ( - which seemed to connect locally, but wouldn't give access to the internet.

Set the DNS servers (Google your ISP and DNS servers).
Wifi off/on - on and it instantly connected and Google Play starts updating apps.