WIFI Issue


New Member
May 15, 2010
Reaction score
I just purchased a Motorola Droid I cannot get my wifi to work. I turn the wifi on and it shows networks. I try to connect and it doesnt seem to do anything. I have tried on a WEP network and a WPA2 network but neither work. when i click to connect to them it doesnt seem to do anything or it says unsuccessful. It doesnt even show the wifi icon on the title bar, and where I turn the wifi on, underneath it says disconnected. when I press it again it shuts it off. Am I doing something wrong here or is it my phone. Please help.
As much as this may sound either like an uneducated guess or an attempt to cop out, many of the connection problems related to WIFI actually stem from wireless routers running older versions of firmware. Before attempting all manner of troubleshooting on the phone, check the router manufacturer's website for the most recent version of your router's firmware and if it's out of date, download and flash the new firmware to your router first. Then try to connect. Don't be surprised if it goes off without a hitch.

Sent from my DROID RAZR using Tapatalk 2
I know the solution.. you can go to wifi settings->advanced->use static ip->fill that up with your information of ip, gateway, dns.....

and it will connect in less than 1 second! :happy3:
I don't know if this is applicable or not but here it is. I was able to connect to other wi-fi network routers but not my home router. A Linksys WRT54G older model. I upgraded the firmware and did a hard reset. No wi-fi. My phone is the Samsung Galaxy SIII but the Samsung support told me to go buy a new router! I was upset because I want to minimize my 4G data usage and being able to connect wi-fi at home is important. Anyways, here is what worked:
Linksys Router Fix

I found a fix if you are having trouble establishing a wi-fi connection between your smartphone and a Linksys WRT54G Router. My router is 8 years old. My SIII could not establish a wi-fi connection with it. I upgraded the firmware and performed a hard reset which did not fix it. Here's what I did:
1. Get into your router - If you didn't already establish a password, leave the username blank and enter "admin" as the password.
2. You should enter Basic Setup.
3. Click on the "Wireless" tab.
4. Go to "Wireless Security. The screen should show the Security mode - (WEP) and the SSID - your( network name) and the passphrase/password There is a button called "Generate." Pressing it generates random 10 digit "Keys" Those keys should have been generated when the router was initially setup.
5. Write down the 4 Keys.
6. Go back to your phone and bring up the network name you are trying to connect with. (Edit)
7. Enter the SSID(Network name)
8. Enter the security - WEP in my case
9. When you get to the "password" field, instead of entering the passphrase or password, ENTER ONE OF THE 10-DIGIT RANDOMLY GENERATED KEYS.

No guarantees but this is what worked for me and now I can work on my phone here at home without racking up 4G data charges. I was fortunate to have found this. Like I said, the router was 8 years old but I didn't want to have to buy a new one. And the Samsung support people did not have any answers for me. They told me to go buy a new router. Give it a try if you're having problems and contact me if I can help. Actually I am curious if that solves your issue. Let me know please
Thanks Bar, this is excellent. Sometimes I am lost when it comes to wifi issues because the problems and solutions can vary. I am marking this for future reference. This seems very similar to what I had to do when I set up my wireless bridge and then couldn't get my tablet to work.


I received an ota update yesterday, 6.13.219.xt894. Since the update, wifi is not working. It shows that it is connected and transmitting (wifi symbol is blue), but I cannot search internet and any app that requires internet does not function. My home router is about a year old, all other devices work fine. I tried my work's wifi and 2 other open networks and same issue. This started as soon as the phone restarted from the update.

Wifi works when I put phone in airplane mode then turn on wifi, but as soon as I turn off airplane mode it no longer works.

Any Ideas as to how to fix this?
Is there any way to rollback the update?

No Root, droid 4
Stack, I would lean towards the security protocols, be it WEP or WPA, or one of the other protocols. Also, look back (above this and your posts) a couple and read both my post and Bar99's. Both provide great starting points for troubleshooting and may ultimately provide the solution as well, like in Bar99's case.
I did a factory reset and the wifi works now, although its so slow its is unusable, screen timeout is set to 2 minutes and it times out before google returns search results.

This isn't just my router, I've tried 4 other locations that, before the update, worked perfectly.

I'm going for a replacement