Water issues/Boot up problem



Okay so last Friday my X decided that it would like to take a swim in a puddle by falling out of my pocket walking from class. I didn't realize it for about 3 min and i ran back to find it and as soon as i got to it i took the battery out and put it in rice when i got home. about 30 min later. dried it out all weekend and put the battery in today and it booted up extremely slowly (about 10 min) and worked "ok" for a while minus all the softkeys.

The screen flickered quite a bit and went black for a while then came back and i thought all was clear. I am rooted and "was" running Liberty GB v.09. i noticed that the green notification led was constantly on as long as the battery was in. i figured it might have something to do with my rom so i decided to SBF back to stock. SBF was successful and ran just as it has numerous times before. went to boot it up and it got to the M logo and stayed for about 30 min with no progress.

Puzzled by that, i decided to SBF again and it completely perfectly. booted up and still on the M logo and has been for about the last 4 or 5 hours. I cannot try and factory reset by holding the home and power key because of the softkeys not working :/ i am trying to think of causes for this and its tough. i am thinking something occured to the memory when i dropped the phone and it will not boot anything else other than what was stored on there? im not too technical but that is my idea.

i am thinking about completely tearing it apart and checking everything over but i was wondering if anyone had any ideas or solutions to this problem. thanks in advance for any help


Sep 23, 2010
Reaction score
Sounds like you've already done the basics. The only solution is exactly what you suggest and that's opening it up to take a closer look. Even though it may be dry, there could be minerals or dust/dirt in the puddle that, though dry, have created improper connections between traces on the circuit board or deposited crud in locations that make buttons fail. Only way to correct it is to open it up and clean it better.

There may be a good tear down video or website out there to help lead you through disassembly. Good luck!


tore it apart cleaned it up and it works good now. only thing is the green led is still a solid green and for some reason it says its in safe mode. i am going to do some more searching and find the causes of those 2 issues. but thank you for you insight. will let you know how it turns out