Unresponsive App Crashes Droid X2


New Member
Jun 5, 2012
Reaction score
I work for a local company doing android app development. I've been working on an app that frequently goes unresponsive. This in itself is not a problem, it is not complete and is a bug I'm trying to fix. However, when it goes unresponsive, it does not display the option to force close the app, nor does it force close the app. It actually takes down the entire phone. Completely crashes and restarts it. At first I thought it was the app, so I kept trying to figure out what was wrong. Tested on other phones (including a Droid X and a different Droid X2), the app works flawlessly, if a smidge laggy. Then other apps (Aldiko, Astrid, even the Browser) on my phone started doing it. They would become unresponsive and crash the phone. I have tried the factory reset. Twice. It has no effect. I have also spoken with the people at the Verizon store, but the people on staff could not help me (read 'refused to help because it was an app I developed that first displayed this problem'). I have searched the web and tried to find others with situations like this, but either my googlefoo is weak, or there haven't been many similar situations. At the moment, I have next to no apps on my phone, 4gb free of internal storage, and 3gb free on the SD card. I am running Android version 2.3.5. If anyone has any idea what could be the problem with my phone, their input is welcome and appreciated.

Edit: I've found what the trigger for the problem is: there are too many processes queued up or running at the same time, and as a result, it hits an out of memory error. However, such an error should not crash the phone. What it should do is freeze the UI, then launch the ANR dialog. It does not do this. I have tried to replicate this on other Droid X2s, but it will not replicate. Those phones respond with correct functionality. Is this a problem I can fix, or do I need to get a new phone?
Last edited: