Syncing won't go away


DF News Team/Mod
Premium Member
Nov 7, 2009
Reaction score
Ok so I updated to the gingerbreadk leaked rom and I noticed that the syncing arrows (2 arrows going in a circle) will not go away...any idea on how to fix it?

Sent from my DROID2 using DroidForums
Go into Accounts & Sync settings, click on your accounts and see specifically which ones are syncing. If there aren't any error signals, click on the account that is syncing to stop it, and restart it. See if that helps any.

I have the same problem and I have all data and sync disabled completely.....I think it may just be that the icon iks appearing when it shouldn't be

Sent from my DROID2 using DroidForums
i have the same issue but at least the deodexed version finally worked haha
I think the only way to fix that problem is by wiping data and factory reset in stock recovery, how I fixed mine.

Sent from my DROID2 using DroidForums
I had this happen as well.

In my instance, it turns out that it actually wasn't the "syncing" arrows I was seeing, but the "media share" arrows. They appear to have dots instead of arrows at the end of the arcs, and it will also appear on the left side of your status bar unlike the syncing arrows that appear on the right. If this is the case, you should be able to turn off media share in the apps settings by unchecking the "show notifications" box when you open the app =)

If it is in fact the "syncing" arrows, however, it probably will take a wipe/factory reset to fix. Make sure that its not your media share first though since that's an easy fix ;)

Sent from my DROID2 using DroidForums
Last edited:
I see that frequently if I flash a new ROM, then restore everything with Titanium Backup. If I let the apps restore on their own, then only restore non-system data for select apps,with TB, it doesn't happen.
I was having the same issues (constantly on no matter what I did the sync symbol would not go away) and it killed my battery extremely fast. I followed some advice (to a certain point) on here and finally found the problem

From home, menu->settings->accounts -> Google account

Then I looked at what I had syncing and found that the SYNC CALENDAR had a rotating sync sign. Once I disabled SYNC CALENDAR the sync symbol immediately disappeared.