(Status 7)


Nov 11, 2009
Reaction score
Medina, OH
I had used SuperOneClick to Root my phone awhile ago. Eventually I used the software to unroot my phone. I removed Amazon while it was rooted and like an idiot I didn't back up the apk. Now that I want to updated to 2.2.1 the update fails. I get the exclamation point when rebooting. I downloaded the update itself from another forum (update.zip) and placed it on the root of my SDcard. I boot the DRIOD while holding X and try to perform the system update. When I do I get the error below. I rerooted the phone using SuperOneClick and placed the apk in the /system/app folder. Then assigned permissions to match the rest of the files. Unrooted and tried to patch via the SD card again, same error. I want to be able to update the phone when needed and don't care if its rooted or not anymore. I would really prefer to not have to flash the phone if I don't have to. I'm hoping there is a way to fix the amazon error I get on update. Suggestions?

Verifying current system...
assert failed: apply_patch_check ("/system/app/com.amazon.mp3.apk", c2a88c45aa6e99c0a0062620c5d2618ea620ef53","c3b285c13bd4b7f8fcfb72372d77b388157bf6cd")
E:Error in /sdcard/update.zip
(Status 7)
Installation aborted.