Smart actions not locating me at home.


New Member
Aug 29, 2012
Reaction score
Razr maxx 4.1 jellybean not using smart actions since upgrading to JB. App doesn't recognize my location at home. Cleared cache, fdr after upgrading, let it find my location, Gps on.
Are you also leaving WIFI on? WIFI is used in conjunction with GPS to enhance the location in Smart Actions. AFAIK, without WIFI on, locations in Smart Actions will not work. Give it a whirl and let me know.

I keep WIFI off whenever possible, but use a program called Wi-Fi Matic - Auto WiFi On Off ( to toggle WIFI automatically for me. This reduces the power consumption, prevents all the "network available" pop-ups, and simply does what it needs to do.

Good luck! :biggrin:
Last edited:
I agree with what FoxKat stated above. To make it work the best, you'll need to have wifi turned on. GPS works but for some reason, it shows my location as a non-existent house number sometimes.

I don't think smart actions is really that smart either. Mine seems to figure out my home wifi, but other recurring calendar based smart actions rarely work properly. I have weekly meetings that occur at the same time each week. Smart actions is set to turn off my ringer at that time. I find that it works about 25-30% of the time. Most of the time it does nothing. I seems pretty useless if you can't get it to be consistent.