screen doesn't work!! all buttons and stuff do

meatbeater

New Member
Joined
Dec 12, 2010
Messages
4
Reaction score
0
it's my moms motorola droid. everything seems to work except the screen. so we have no what idea what is going on because we cant see.

any ideas? phone is passed the one year warranty :(
 

CJM

Super Moderator
Staff member
Premium Member
Rescue Squad
Joined
Sep 12, 2010
Messages
10,604
Reaction score
1,749
Location
Mississippi Gulf Coast
Current Phone Model
Nexus 6
Twitter
https://twitter.com/Corey
I've heard of this and people call it a bad digitizer(I think). When this happens they say they can swipe their finger over the lock buttons and feel it vibrate like it unlocked, but the screen stays black. I've seen one of our member, FURBEARINGMAMMAL, describe this. Maybe PM him, he's all over the place in this forum, and ask him. If its under a year old(and not rooted) its still under warranty. Bring to a VZW store and see what they say.
 

furbearingmammal

Super Moderator
Joined
Jun 16, 2010
Messages
11,081
Reaction score
365
Location
Anywhere you're not
Website
swdouglas.blogspot.com
Current Phone Model
32GB Moto X Developers Edition
Twitter
furryvarmint
CJM is right. If it's less than a year old and rooted you'll need to get it back to stock before taking it in. If it's not rooted then just take it into a Verizon store -- or call support. They'll send you a CLN (certified like new) replacement. I'm currently on one and I have to say that, other than the USB port being surprisingly loose, it's tight as a snare drum. The digitizer is actually a little more responsive than my old one, too.

If it's slightly over a year old then contact Motorola. They might still have a warranty on it. If it's a release-day one you're probably out of luck, though. But jump on this ASAP. The sooner you get it fixed the sooner you look like a hero, and the longer you wait the closer the warranty expiration date comes. :)
 

buffalofan

New Member
Joined
Apr 10, 2011
Messages
2
Reaction score
0
Hello, I have a Droid R2D2. I have had it since februray. It has been fine up until today when I accidentally put it in a bag with dry mud inside. This made the sliding mechanism very hard to use. I very little water and windex on the back slider piece and slid it up and down. I then wiped all of the excess liquid from it. It worked like new up until an hour or two later when the screen started to flicker. I locked it then unlocked it and it still flickered. So I turned it off and turned It back on and I saw the moterola sign flicker then disappear. All of the buttons work, it still charges but I cant see a thing! Please help!
Thanks, Buffalofan
 
Top