Rooting HTC Rhyme


Sep 16, 2010
Reaction score
Baltimore, MD
I just bought my wife the HTC Rhyme and I need to root it but I having trouble getting it done.

I have the Incredible and I rooted it within a month of getting it, initially just to get rid of the bloatware. My wife is in the same state of mind that I was when I got my phone. She can't wait to get rid of the crap that came with hers.

I have one problem that is at least a contributing factor. I can't seem to get the ADB drivers to install. I've downloaded several from different sources, including SDK and the results are the same. I plug in the phone and follow the xp found device prompts to install the drivers. I navigate to the driver location and click "OK" and I keep getting the same "hardware cannot be installed" message due to lack of required software. I've tried going through device manager and same there too.

The method I was trying to root the phone with was here... [ROOT]Sensation XL permanent root method. - xda-developers ...which was linked from another forum that said this was the way to go for rooting the HTC Rhyme.

I run the ZergRush script and most of what I get is line after line of failed operations that are followed by "device not found". Although, some lines do say that the device was found, so it's not just a connection problem. The phone is fully conntected to the PC, debugging and unknown sources enabled. I even went through the HTC bootloader unlock process which was successful, but I'm still not getting root access.

Any help would be most appreciated.

- Have you downloaded and installed HTC Sync (from the HTC website)? That should install the drivers for your phone.

- As for rooting....'fraid that's not my dept. Good Luck!
Hi... thanks for the reply.

Yes. I did download the latest HTC Sync and ran it, but there was no change. HTC Sync never responded to the phone being plugged in.

As far as the drivers go, I think I'll be OK now. I got back on my computer last night, hooked the phone up and the task bar pop-up acknowledge the device and said "Android Phone"... "My HTC". I checked device manager and "Android USB Devices" was listed at the top wit a green PC board icon. However, the zergRush root tool is still not working.